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The Educational BoosterPack MKI| offers a high level of integration for developers to quickly
prototype complete solutions. Various analog & digital inputs/outputs are at your disposal

including an analog joystick, temperature sensor, RGB LED, microphone, buzzer, color LCD
display & more!

Find more information such as hardware design files, code examples, documentation & more @
www.ti.com/tool/BOOSTXL-EDUMKII

This BoosterPack complies with the BoosterPack pin out standard that is outlined @ ti.com/byob
& should pair well with most Tl LaunchPad evaluation kits.

Educational BoosterPack MKII shown with
MSP-EXP430F5529LP (not included)

/Z0ZZSS/|/WOd" I MMM “Jswiesiq
*SI9UMO BA0adSal 1By} Jo Aladold By} aie SyJewapel} JAUJ0 || “SJUBINIISU| SBXa | JO SHIeWwapel;
ale 0IpN}g 18sodwoD 8pod pue ‘ZedSIN ‘0SPdSIN “eq wuoge|d 8y “pejeiodioou] sjuswinisu| sexa] G102 @

3AI ,, 0IPNIS Jesodwo) 8po 3q| eibisug

3a1pnoiD SO0 - e
PNo|D Jaiojdxg 8oinosey - } EUOSISR

SO0/W09°N} nuelBious’ mmm

‘PedyouneT yum aow 'siosuss Buisuss g
R So|qeleA yolem ‘sjulodsealq  siezznqg Buizzng ‘sg3T Buulg
10S "Aujigqedeo Bngap |Iny 10} suonouny 8sn-0}-Aseg
apino.d eyl s3q| [euoissajoid *10}IP8 SP0Y USAUP-AHUNWIWOD
Aq papoddns osfe s| pedyoune] @ 90inos-uado a|dwis
S|00} 8J/EMYOS [BUOISS8J0.d elbioug

iSI00L PNOID | L YHM Jesmoiq
gam JnoA ul Apjoinb papess 105
$|001 pPnojD |L

S|00] °@JeM}joS

S)0edI9}S00Q/WOD’) @ |[B Way} 89S ¢
Buisuag [eyuswUOIIAUT -
AUAOBUUOD SSBIBIIN -
she|dsiq -

:apn|oul syoedJalsoog "ubisap JnoA jo Ajjeuoriouny ay3 aoueyus Ajyea.lb

0} pedyouneT a|buls e uo syoedJaisoog s|dijnw 3oeis ‘saiped pJiyl

pUB SjusWINIISU| SEXS] Y10q WO} |qe|iene syoedJsisoog asodind [essush
pue ay1oads-uoneoldde jo sbue. peoiq e s| a4ay] "s|qeus ued NOI |L
9]1I0AEB} INOA Jey) suoljeoljdde Juaiayip aiojdxa 0} NOA Mojje 0} pedyouneT]
ay} uo suid uspeay a8y} ojul Bnjd ssinpow ui-6n|d yoedieisoog

wolsAs00] yoed4a1s00g

In addition, this BoosterPack was developed with Energia in mind. Energia is an open source,
community developed coding environment, which is supported by a robust framework of
intuitive APIs & easy-to-use software libraries for rapid firmware development. We recommend
Energia v15 or later. Learn more about Energia @ www.energia.nu

) | 1 )Select the LaunchPad you are developing with:
2) See the many Educational BoosterPack

MIKII | " Tools > Board > [Select your board]
examples at: Also select the COM port your LaunchPad i ted to:
File > Examples > EducationalBP_MKIl S0 select he porl your Launchiad Is connected o:

Tools > Serial Port > [Select your port]
Ih% === ]
3)Verty & Upload J

Compile & load your void setup() {
code to the LaunchPad.

@ Blink | Energia b Anz

File Edit Sketch Tools Help

Energia features a

built-in Serial Monitor
// initialize the digital pin as an output.

pinlode (37, OUTPUT);
}

// the loop routine runs over and over again forever:

woid loop{) { P> This is the blinky example.
ligitallirite(37, HIGH); // turn the LED on (HIGH is the voltage level) This will cause the blue
(1000) ; // wait for a second LED Ed i |
te(37, LOW): // turn the LED off by making the voltage LOW on your Educa Ion.a
27 {1000) ; // wait for a second BoosterPack MKII to blink

once per second!

Challenge:
Try blinking the other LEDs or
changing the blink speed!

LaunchPad w/ m

Energia is available for Windows, Linux & Mac OS X.



A closer look at your new BoosterPack Plug-in Module

Use the TMP006 & OPT3001 Library to get the sensor
readings from these sensors. TMP0O6 returns temperature,
while the OPT3001 reports back ambient light brightness.
TI OPT3001 TI TMP006
Light Sensor Temp Sensor

J4.39
Jumper select

12C_scL: J1.9 | [12c_scL: J1.9
RED_LED (RGB — -
LED( )l |LCDB Wiaht GNDL  12C_SDA: J1.10| | 12C_SDA: J1.10 LJ4.34
ackilg INT_PIN: J1.8 INT_PIN: J2.11 @

2-axis Joystick w/
Pushbutton

0000000000
0000000000R
00000000005
0000000000R

HOR(X): J1.2 Use the analogRead(pin_number)
VER(Y) J3.26 function to read the raw analog Use the LCD library

. channels for each direction. to display text, images
SEL: J1.5 Use digitalRead(pin_number) to & basic shapes on the

read the state of the SEL button. Buzzer

{

screen.

j

J4.40

Use analogRead(pin_number) MiCrOphOne
to read the raw analog values

from the microphone.

40 pin stackable

116 BoosterPack

Connector

Pinout Diagram for your BoosterPack

Servo Motor
Connector

3-axis
accelerometer

X:J3.23
Y:J3.24
Z:J3.25

j

User Push
Buttons

RGB Multi-

Color LED

BLU: J4.37
GRN: J4.38

RED: J4.39

j

Use tone(pin_number, frequency)
to output a tone at a specific frequency.
Try to import the "tone" library in Energia.

Use Servo Library to change
the position of the servo motor

j

Use digitalRead(pin_number)
to read the state of these input pins.

Use analogRead(pin_number)
to read the raw analog channels

Use analogWrite(pin_number, brightness)
to output PWM at each RGB channel

Alligator Clip Use digitalRead(pin_number) function
to read the state of this input pin
Connectors pue
The alligator clip connectors allow you to turn almost anything
into an input. To use, hold the ground wire in one hand, then
use your free hand to touch the object that the other cable is

GND

. connected to. The state of the output will change when you
“, close the circuit!

%

Get started quickly:
mp www.ti.com/BOOSTXL-EDUMKI| 4mm

Download & install Energia (v15 or newer), an open-source
rapid prototyping coding environment @ www.energia.nu
Once installed, plug your BoosterPack into your LaunchPad,
then plug your LaunchPad to your computer via USB.

Tell Energia which LaunchPad you are using with your
BoosterPack by navigating to:

Tools > Board > [Select your board]

(Recommended Devices: MSP432P401R & TM4C123)

2

Once installed, browse through the many examples for the
Educational BoosterPack MKII by navigating to:

File > Examples > EducationalBP_MKII > [Examples]
Examples exist for all of the components featured on the
Educational BoosterPack MKII.

3

You should now be on your way to creating new LaunchPad-
enabled applications. Happy coding!
Need support? Checkout &

Educational BoosterPack MKII Pinout

3.3V
JOYSTICK, HOR(X
UART,BP=+LP
UART, BP« LP
{_JOYSTICK, SELECT

3.3V
Analog In

RX (—MCU)
UART X ((—MCU‘l

GPIO

[O)

{(MICROPHONE
LCD, SPI CLK
AMBIENT LIGHT (OPT3001), INT
TEMP SENSOR (TMP006), I2C
TEMP SENSOR (TMP006), 12C

(Analogin___}
(sPiclk )

SPI CLK
GPIO

12C

[O)
SCL
SDA

AMBIENT LIGHT (OPT3001), I2C
AMBIENT LIGHT (OPT3001), 12C

5V

GND
ACCELEROMETER, X
ACCELEROMETER, Y
ACCELEROMETER, Z
JOYSTICK, VER(Y

5V

GND

( Analo§ In }

Analog In

( Analo§ In )

Analog In

Analog In

Analog Out

Analog Out

Be sure to check the pinout of the specific LaunchPad you are using to ensure full pin compatibility.
For more information on the BoosterPack standard, check out www.ti.com/byob
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—
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Educational BoosterPack MKII Pinout

GND
PWM out GPIO [O)
{ SPI CS wireless GPIO [O)

{(GPIO* }—
RESET

MOS|
[SP miso

{SPICSosey  HGPIO T (M)
(SPICSover  HGPIO  H_(M)

(Pl L (M)

MP SENSOR (TMP006), INT }

BUZZER OUT {PWM out Hcrio (M)
RGB_LED, RED H{LCD, BACKLIGHT H—{PWM out GPIO
RGB_LED, GRN {PWM out GPIO @)

RGB_LED, BLU
(Timer CaEture )—_-_GPIO

Timer Capture [©)

GATOR HOLE, I/0 GPIO [O)

(GPiIo_ H ())
{(cPio { Z)]

GPIO [@)

BUTTONT1, I/O
BUTTON2, I/O
LCD, RS PIN

Denotes that these pins are not connected (NC)




IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESDA48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI's terms and conditions of sale
supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI's terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent Tl deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.

Tl assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from Tl under the patents or other intellectual property of TI.

Reproduction of significant portions of Tl information in Tl data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. Tl is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
Tl is not responsible or liable for any such statements.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify Tl and its representatives against any damages arising out of the use
of any Tl components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI's goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.

No Tl components are authorized for use in FDA Class Ill (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.

Only those Tl components which Tl has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, Tl will not be responsible for any failure to meet ISO/TS16949.

Products Applications
Audio www.ti.com/audio Automotive and Transportation www.ti.com/automotive
Amplifiers amplifier.ti.com Communications and Telecom  www.ti.com/communications

Data Converters
DLP® Products

DSP

Clocks and Timers
Interface

Logic

Power Mgmt
Microcontrollers
RFID

OMAP Applications Processors
Wireless Connectivity

dataconverter.ti.com

www.dlp.com

dsp.ti.com
www.ti.com/clocks

interface.ti.com

logic.ti.com

power.ti.com
microcontroller.ti.com

www.ti-rfid.com
www.ti.com/omap

Computers and Peripherals
Consumer Electronics
Energy and Lighting
Industrial

Medical

Security

Space, Avionics and Defense
Video and Imaging

Tl E2E Community

www.ti.com/wirelessconnectivity

www.ti.com/computers

www.ti.com/consumer-apps

www.ti.com/energy
www.ti.com/industrial

www.ti.com/medical

www.ti.com/security
www.ti.com/space-avionics-defense

www.ti.com/video
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