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ABSTRACT
TI’s DRV9x family of parts are motor driver integrated circuits (ICs) with an integrated MSP430 core and
3-phase brushless DC (BLDC) predriver. These ICs require Code Composer Studio™ (CCS), device
drivers, and MSP430UIF tools to communicate via the JTAG communication. This document details the
entire installation and programming tool setup using CCS. This integrated development environment (IDE)
offers full debugging and developmental capabilities. A detailed pictorial step-by-step description of each
block is also included in the document. All specific files needed for the DRV9x are included in the software
development kit (SDK) install package, CCS must be installed separately.

Figure 1. Flow Chart for Installing and Configuring Code Composer
Studio for the DRV9x Family of Devices

Code Composer Studio is a trademark of Texas Instruments.
All other trademarks are the property of their respective owners.
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1 Installing CCS
CCS versions 5 and 6 have been tested with the DRV9x. An authorized version can be installed from
http://www.ti.com/tool/ccstudio. Please note a myTI login account will be needed to download CCS as well
as the SDK package. The following walk-through is the installation procedure for CCS5.4; however,
installing other versions including v6.x is similar.

After following the necessary steps to download the CCS installer, there should be a file
ccs_setup_5.4.0.00091.exe located in the specified download directory. See Figure 2 below showing this
file.

Figure 2. Downloaded Executable for Code Composer Studio Installation

Follow the installation process listed below:
1. Run the installer by double-Clicking cs_setup_5.4.0.00091.exe. Read through and accept the license

agreement to proceed with the installation.

Figure 3. CCS License Agreement
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2. Choose a destination directory. Using the default (c:\ti) will remove a step in the SDK installation
procedure.

Figure 4. Default Installation Location for CCS

3. Choose the processor architectures to install.
For the DRV9x, the MSP430 package is the only needed processor.

Figure 5. Processors Supported by CCS
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4. Select the components you wish to install.
The compiler tools are needed, ensure TI MSP430 Compiler Tools and Documentation are both
selected. The device software MSP430ware, Grace, and SYS/BIOS v6 are optional.

Figure 6. Components Available for Installation

5. Choose the emulators
For the provided tool, MSP430-FET430UIF, the MSP430 USB FET emulator is needed.

Figure 7. Emulators Available for Installation
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6. Review the installation and finalize.
The last menu before the installation is underway shows the selected options and requirements. If
everything looks correct, click the Next button. CCS will begin to install.

Figure 8. CCS Installation Review

When reporting a problem, it's important to be able to capture details about the particular setup. In CCS
you can view specific software details, under the Help menu select About Code Composer Studio. Next
click the Installation Details button. This menu describes different aspects and details of the installation
including history, configurations, tools and compiler version. The Configuration tab displays a file
containing various pieces of information about the setup, including plug-in versions, preference settings,
and the contents of the internal log file. You can copy and save this information and attach the saved file
to your problem report.

Figure 9. About CCS Software Installation Details
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2 Installing DRV9x Software Development Kit
There are files needed to program the DRV9x with CCS. All of these files are included in the installation
package of the SDK which can be downloaded from TI’s secure software download site. To get access to
this download please contact the DRV9x applications team or the respective field sales engineer. Please
note the following steps are for the DRV91680; however, the procedure is the same for different DRV9x
devices.
1. To begin, double click the SDK executable after downloading it from the TI website.

Figure 10. SDK Installation Executable

2. The default setup language is in English, if the user opts for a different language the follow prompt
allows the user to change the language.

Figure 11. Language Selection for the Driver Installer

3. Read though and accept the license agreement to proceed with the installation.

Figure 12. DRV9x SDK License Agreement

4. Ensure all running instances of Code Composer Studio are closed.
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Figure 13. Warning Message to Exit CCS Before Installation

5. The default installation folder is specified as the default CCSv6 installation location. If CCv6 was
installed in the default directory (C:\ti) then proceed. If CCSv5 was installed or the location of v6 was
changed the SDK must be installed in the ccs_base folder. In the previous installation example, the
CCS path is C:\ti, if that is the case, the SDK should be placed in C:\ti\ccsv5\ccs_base.

spacerspacerspacer CAUTION this path might need to be modified.

Figure 14. SDK Installation in CCS Base Directory

6. Choose a destination location for the SDK documentation and example CCS projects. This can be set
to any location on the PC.
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Figure 15. SDK Collateral Destination Folder

7. Continue with the installation process. Select the Next button to install after reviewing the settings and
click the Finish button when procedure is done.
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3 Creating or Importing a Project into CCS
When working with CCS, it will initially ask to select a workspace. A workspace is the structure in which
projects are kept and there can be multiple projects in one workspace. To begin with, CCS it is suggested
to import the provided project for the specific DRV9x device. After importing an existing project the user
can explore the features of CCS and get used to the IDE. Follow these steps for importing the provided
project:
1. Double click the CCS ICON to open the application. A CCS icon is placed on the desktop after

installation.

Figure 16. CCS Desktop ICON

2. Select the location and name of the workspace. This selection is up to the user’s preference on the
location and naming convention.

Figure 17. Workspace Launcher Window
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3. After selecting the workspace, CCS opens showing a welcome menu. From here you can select
Import Project or go to the Project menu and click Import Existing CCS Eclipse Project.

Figure 18. Import Project Options

4. A new window appears showing options for importing the project. Click the browse button and find the
provided projects through the folder browser. These projects are located in the SDK installation
directory. The above example location is C:\ti\DRV91680_SDK. Once selected, the provided project
appears under Discovered Projects, make sure it is selected and then press the Finish button.

Figure 19. Import Project Menu
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5. Now the project should appear in the Project Explorer window. Explore, build, and run the project from
here.

Figure 20. CCS Build and Debug

6. To create a new project, start by clicking on the File menu and select New, then CCS Project. A new
window appears:
(a) Fill in Project Name
(b) Under the Family pull-down menu, select MSP430
(c) Select DRV9XXXX as the Variant and the specific device in the adjoining field

NOTE: If the DRV9xxxx is not showing in the device sub-group, the device drivers need to be
reinstalled (see Section 2).
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Figure 21. Creating a New Project Menu Items

For older projects:

CCS v4 Projects—CCSv4 projects can be imported and are automatically converted to the newer format.
Use Import Existing CCS Eclipse Project under the Project menu.

CCS v3.3 Projects—CCSv5 uses the Eclipse concept of projects. To help import existing projects into
CCSv5.1, use the project import wizard. Under the Project menu select Import Legacy CCSv3.3 Project.
This starts a wizard that guides the user through the conversion process.

If further resources are needed for using CCS, consult the guides and support under the Help menu.
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4 Updating the MSP-FET43OUIF
After the reference project is imported and selected in CCS, the provided software will build and run on
the DRV9x device. The device is programmed by the MSP-FET430UIF. When this device is used, CCS
automatically detects the firmware version and notifies of an update. The process takes a few minutes, let
the update complete before unplugging the USB cable or closing CCS. See Figure 22 and Figure 23 for
images depicting the update process.

Figure 22. Notification of Firmware Update

Figure 23. Update Progress Window

NOTE: To prevent any damage, it is important to wait for the update to finish before unplugging the
MSP430UIF tool or closing CCS.
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESD48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI’s terms and conditions of sale
supplied at the time of order acknowledgment.
TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI’s terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent TI deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.
TI assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of significant portions of TI information in TI data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. TI is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.
Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
TI is not responsible or liable for any such statements.
Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify TI and its representatives against any damages arising out of the use
of any TI components in safety-critical applications.
In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI’s goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.
No TI components are authorized for use in FDA Class III (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.
Only those TI components which TI has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.
TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, TI will not be responsible for any failure to meet ISO/TS16949.

Products Applications
Audio www.ti.com/audio Automotive and Transportation www.ti.com/automotive
Amplifiers amplifier.ti.com Communications and Telecom www.ti.com/communications
Data Converters dataconverter.ti.com Computers and Peripherals www.ti.com/computers
DLP® Products www.dlp.com Consumer Electronics www.ti.com/consumer-apps
DSP dsp.ti.com Energy and Lighting www.ti.com/energy
Clocks and Timers www.ti.com/clocks Industrial www.ti.com/industrial
Interface interface.ti.com Medical www.ti.com/medical
Logic logic.ti.com Security www.ti.com/security
Power Mgmt power.ti.com Space, Avionics and Defense www.ti.com/space-avionics-defense
Microcontrollers microcontroller.ti.com Video and Imaging www.ti.com/video
RFID www.ti-rfid.com
OMAP Applications Processors www.ti.com/omap TI E2E Community e2e.ti.com
Wireless Connectivity www.ti.com/wirelessconnectivity
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