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Preface

Read This First

About This Manual

This user’s guide describes installation instructions, reference information,
and troubleshooting for the Windows Interface Speech Development Station
(WINSDS).

How to Use This Manual

This document contains the following chapters:

Chapter 1  Introduction to WINSDS
This chapter describes WINSDS features, SDS5000 compatibility,
WINSDS user interface, toolbar, status bar, and scale bar. It also de-
scribes the management of the various windows, selecting a mouse, and
keyboard commands.

Chapter 2  Hardware and Software Requirements for WINSDS
This chapter describes the hardware and software requirements of the
WINSDS system.

Chapter 3  Installing WINSDS
This chapter describes the hardware installation, software installation,
and the audio connections of WINSDS.

Chapter 4  Starting WINSDS
This chapter describes starting WINSDS, creating a new application, set-
ups, opening an existing application, and word setup.

Chapter 5  Inputting, Playing, and Viewing Signals
This chapter describes playing a signal, importing a WINSDS or SDS5000
word, the recording process, and viewing signals.

Chapter 6  Editing A Document
This chapter describes the various commands needed to edit a document.

Chapter 7  List
This chapter describes creating a list, opening an existing list, list com-
mands, viewing a list, reading a list, and finishing a list.
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Chapter 8  Saving and Printing Your Work
This chapter describes saving and printing your work, quitting WINSDS,
and deleting unwanted files.

Chapter 9  ROMSDS
This chapter describes ROMSDS, how ROMSDS works, ROM data orga-
nization, data representation and coding, and starting ROMSDS. This
chapter also includes a sample assembly file.

Chapter 10  Sound Editor
This chapter describes features of, starting, and running the sound editor.
A function description of all the sound editor commands is also given.

Chapter 11  Trouble Shooting
This chapter gives hints for solving various problems when installing and
running WINSDS.

Appendix A  LDS Analysis
This appendix gives a brief description of linear predictive coding (LPC)
and how WINSDS uses LDS.

Trademarks

TI and WINSDS are trademarks of Texas Instruments Incorporated

Microsoft, Windows, Windows 3.1, Windows 95, Microsoft Visual Basic, Micro-
soft MSDN, Windows Explorer are trademarks of Microsoft Corporation

IBM and PC are trademarks of International Business Machines Corporation.

Pentuim is a trademark of Intel Corporation.

SampleVision and SMP are trademarks of TBD
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1.1 Background

Welcome to the Texas Instruments Windows Interface Speech Development
Station (WINSDS). WINSDS represents a revised and expanded version of
the SDS5000, specifically designed to speed up the process of large
vocabulary development. It is an inexpensive, user-friendly tool that is
powerful enough for the nonspeech expert to produce high-quality linear
predictive coding (LPC) and modified code-excited linear prediction (MELP)
speech and sounds after working on the station for a short time.

1.2 New Features

The Windows-based WINSDS is a successor to the SDS5000 speech
development station designed to produce synthesized vocabulary. It is read-
compatible with the files generated by the SDS5000. Like the SDS5000
station, the WINSDS station runs on an IBM-PC or compatible. The following
are newly implemented functions on WINSDS:

� Start-Up

� Full start-up process (program manager icon, file execute, and
parameter passing)

� Multiple programs

� Task alternation

� SDS software runs without an analog development board

� Start-up options

� Database management tools (search folder for label, access to
MSWord from another folder)

� On-line board initialization

� On-line configuration parameters

� Application setup parameters

� User-defined analysis parameters

� New analysis parameters (e.g., new pitch parameters)

� Modification of analysis parameters (e.g., at the application level:
hamming window, voiced pre-emphasis, etc.)

� Mouse- and keyboard-oriented interface

� Quick screen display



New Features

1-3Introduction to WINSDS

� Window Displays

� Window selection and tiling

� Dual-channel capability (edit 2 channels simultaneously)

� Simultaneous signal display

� View word access table (words in the application)

� View current channels (signal display)

� Edit list capabilities

� View compiled lists in database

� Play

� Play pad

� Play: Selection, word, all, frame

� Stop play of synthetic speech

� Play selected word(s) in a list

� Automatic word labeling (apply scenario)

� Edit

� Read/edit/add/delete word window

� Comment zone for each word label

� Frame modifications: Mark frame for future reference, split frame,
concatenate split frame, repeat frame, skip frame

� Binary files

� Format editing

� Create various word versions

� Print signal display, numerical modifications, etc.

� View

� View word and application status
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� Setup

� Hardware configuration

� Application/word setups

� Recording/audio setups

� Adjust memory allocation

� Colors

� Help

� On-line Help

1.3 SDS5000 Compatibility

� File

� File loading/saving/editing functions

� Compatibility with SDS5000 files (read-only)

� Signal editing (read a word, read a list)

� Signal selection with mouse (frame, selection of frames, word, list of
words, zoom selection, etc.)

� View

� View application status

� Zoom in/out (X-axis/Y-axis) and select/zoom

� Record

� Unlimited signal input duration

� Record a word/phrase/word-by-word and LPC analysis

� On-/off-line Analysis

� Play coded and uncoded synthetic speech (speed selection, all/word/
selection/frame play)

� Play a list (original or synthetic speech) with optional silence zones

� Reset (initialize) signal window
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� Edit

� Cut/copy/paste word or frame selection

� Split and concatenate words

� Insert silent frame

� Modify

� Measure/modify/recalculate pitch (step-by-step)

� Pitch interpolation

� Modify voiced or unvoiced frames

� Pitch and energy slope alteration

� Single parameter/word parameter modification

� Variable application/word compression rates

� Options

� Adjust input level display with maximum-level and saturation-level
indicators

� Adjust input/output gain

� Flexible numerical editing (Ki editing)

1.4 WINSDS User Interface

The user interface of the WINSDS station was designed using Microsoft Visual
Basic  under Windows 3.1x  and Windows 95 . The user interface is
designed to conform as closely as possible to Microsoft MSDN  User
Interface guidelines and IBM  Design rules for User Interface.

Screen Zones

The WINSDS interface features a main MDI window containing all other
objects: a title bar, menu bar with drop-down menus, toolbar for quick menu
item selection, a display zone with all windowing features, and a status bar at
the bottom of the screen.

Mouse- and Keyboard-Driven Actions

Most actions can be performed using the mouse to select menus and option
buttons. The keyboard can speed up operations for the experienced user. Key-
board commands are given on the menus for most (but not all) commands.
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1.5 The Toolbar, Status Bar, and Scale Bar

1.5.1 Toolbar

The Toolbar is a permanent display at the top of the main WINSDS window.
It gives the date and time and light-icons for record and play operations. These
operations and the following icons can speed up operations:

1.5.1.1 Edit

Read a word in Channel 1: The Select Word appears as topmost
window

Read a list in Channel 1: A prompt for the list number appears

Display the Edit Label and Comment as topmost window

Display Edit Lists window

Mark frame for future reference

 Display Measure Pitch Modal window

Display numerical modifications

1.5.1.2 Record

Record one word

Stop Recording or stop current Play function

Repeat last Play or Start Playing All Original

Display Play Pad as topmost window

1.5.1.3 View

Display Application Status window



The Toolbar, Status Bar, and Scale Bar

1-7Introduction to WINSDS

Zoom in on X-axis

Zoom out on X-axis

Zoom in on Y-axis

Zoom out on Y-axis

Replace signal (default)

Add a signal

Select parameter in multiparameter display

1.5.1.4 Help

Help

1.5.2 Status Bar

The Status Bar is a permanent display at the bottom of the WINSDS Main
window. It contains the following information on the current word and current
frame:

� Word label

� Vs is the word version

� Frame Nb is the current frame number at the cursor position

� F0 is the current frame fundamental frequency in Hz

� F0 is calculated as F0 = (16 × FREQ)/T0 with

� T0 is the calculated pitch for the frame in (1/16 of a sample) units

� FREQ is the sampling frequency

� UV is displayed if the frame is unvoiced.

� T0 is the current frame’s displayed pitch as samples
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� A0 is the current frame’s displayed energy

� Fr.Reps. is the number of times the current frame is repeated during
compressed speech

� FSI is the current frame split indicator

� Wrd.Thr. is the current word default compression threshold

� Fr.Thr. is the current frame default compression threshold

1.5.3 Scale Bar

The Scale bar (located below the Signal window) is used to identify word
boundaries in a List (Concatenation) as well as the frame boundaries in each
word. A word boundary is indicated by a vertical green line along the Scale bar,
while a frame boundary is indicated by a vertical white line. The distance
between two frame lines represents frame duration:

Figure 1–1. Scale Bar

The Scale bar also displays the following additional frame commands:

Repeat frame

Split frame

Skip frame

Mark frame for future reference
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1.6 Windows

1.6.1 Manipulating Windows and Icons

� Manipulating Windows using the WINDOW Menu:

� Minimize (Shrink to Icon): Minimizes or shrinks a selected window to
an icon.

� Maximum Form: Maximizes all windows.

� Cascade: Cascades windows that are not in icon form.

� Default (normal size): Resets a selected window to normal size.

� Manipulating Icons using the WINDOW Menu:

� Icons on Background: Removes icons from the screen. You may also
double-click on each icon.

� Icons on Foreground: Displays all hidden icons.

WINSDS is a multiwindow application that enables the user to view or
manipulate data displayed in each window. Every window appears in the Main
MDI window, the area between the Toolbar at the top and the Status Bar at the
bottom of the screen. WINSDS uses the following types of windows:

� Signal windows

� Status windows

� Modal windows

� List windows

� Topmost windows
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1.6.2 Signal Windows

Signal windows display a word or a sequence of words called a List. Signal
windows display the original signal and analysis results. Each window
contains three displays:

� Sound waveform of the original signal

� Ruler separating the signal into a series of temporal frames

� Pitch and energy contours [or other specified parameter(s)] resulting from
analysis

Figure 1–2. Signal Window

The name of the type of curve (e.g., Pitch, Energy) appears in the upper right
corner of each display. The X-axis scale is measured in frames starting with
Frame 1. The frame number and the curve value at the cursor position on the
Y-axis appear in the upper left corner of the window.

Note:

Two sets of windows can be displayed simultaneously for the dual-channel
MSP50C30. Pitch and Energy windows can be changed to display selected
K-parameters from the LPC analysis of each signal.

Signal windows can be minimized (displaying the entire signal) or maximized
(one screen pixel displaying each frame sample). Zooming in and zooming out
are possible on Signal windows (See Section 5.4, Viewing Signals).
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1.6.3 Status Windows

There are four types of status displays:

� Application Status window

Displays general information about the application of the SDS board and
analysis setup information (e.g., Method, Chip, Coding table). Most
parameters can be altered by clicking on the desired option for each
parameter.

� Word Status window

Displays information about the word at the current cursor position:

� Channel speech signal duration

� Clipboard buffer duration (i.e., memory remaining)

� Original/synthetic/compressed duration of last play

� Original/synthetic number of frames

� Word Status table

Displays the status of all words in the application:

� Unrecorded words

� Unanalyzed words

� Uncoded words

� Unused words

� Words used in (optional) current list file

� Status Bar

Displays information about the current word and current frame, (see Section
1.5.2, Status Bar).

1.6.4 Modal Windows

Modal windows are prompts for information. They cannot be closed until the
requested information has been input.

Figure 1–3. Modal Window
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1.6.5 List Windows

There are two types of List Windows:

� List Window: Shows the current list file containing a set of numbered word
concatenations or Sentences called Lists for an application.

� Object List Window: Shows the Object List in the database. An Object List
consists of the compiled lists (of the current List File) for one or two
channels. For two channels, a Sentence appears as a collection of
formatted labels (rather than signals). The display format is the same as
for the list window: Two channels contain the current lists, one per
channel, (For more information, see Chapter 7, Lists).

1.6.6 Topmost Windows

Topmost windows are windows displayed permanently in front of all other
windows. They are used for multiple actions or interaction between two or
more windows.

� Select a Word window: This window appears with various titles depending
on the action to be taken. The Select a Word window appears when you
click on the word and then on OK. Here, the window acts like a normal
window, disappearing while an action is being performed. However, if you
double-click on the word, the topmost window remains visible while the
action is performed.

The Select a Word window is used in the following cases:

� Read a Word: Words are displayed in a list with associated version (1, 2,
etc.) and signal numbers (01, 02, etc.) Clicking on a word causes the
signal, pitch and energy curves to be displayed.

� Analyze a Word

� Delete a Word

� Add a Word: Displays the signal of a new word in addition to the currently
displayed signal.

� Edit Label: Displays Edit Label window used to label a word and write an
optional comment.

� Play Pad can be used as a time-saver for Play operations in place of using
the menus.
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1.6.7 Managing Windows

� Reset Signals: Used to reset or clear the Signal windows so that they are
empty.

� Tile Forms Horizontal: Horizontally tiles (arranges) forms that are not in
icon form.

� Tile Forms Vertical: Vertically tiles (arranges) forms that are not in icon 
form, (See Figure 5–12. Signal Drop-Down List Box).

� Close Form: Closes the current window. You can also double-click on the
upper edge of the window to close the form.

1.7 Selecting with the Mouse

� Menus and Options: Click on the selected menu, submenu, item, or option
(e.g., OK).

� Word Selection: A word may be selected by double-clicking on the word
signal.

� Selection: This feature is useful in playing Selections (parts of the
displayed signal). A Selection is made by holding down the left mouse
button and dragging the cursor. When the mouse button is released,
Selection stops. If desired, a Selection can be dragged horizontally using
the left mouse button. A Selection may be canceled by slightly moving the
cursor while holding down the left mouse button, or by pressing DELETE .
A Selection can be shortened or lengthened by pressing SHIFT  and using
the →  and ←  keys. Unselect also cancels the previous Selection. To
Unselect, move the cursor slightly, but do not make a Selection.

� Zoom: A portion of the signal display can be magnified or viewed more
closely (Zoom In). First, select the part of the signal you wish to view. Then,
use PAGE DOWN  or click on the Zoom icon to Zoom In on the X-axis.

� Cursor: The cursor is moved either by clicking on the signal display with
the left or right mouse button held down or by using the → / ←  keys.
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1.8 Keyboard Commands

1.8.1 Working with Menus and Options

Each menu and submenu option in WINSDS may be accessed by keystrokes,
usually a combination of ALT  plus a letter ( A , B , C , etc.). For example, to
access the File Menu, use the underlined letter as the access letter [e.g., a
combination of ALT  + F  (from FILE)].

In some cases, items or functions may be accessed directly by using a function
key or combination of keys. For instance, F12  displays the Word Access Table,
while CONTROL  + I  inserts a Silent Frame. Keyboard commands are
displayed in the menus, as shown in Figure 1–4.

Figure 1–4. Edit Menu
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1.8.2 Moving the Cursor

As stated previously, the cursor is moved to the right or left along the displayed
signal by using the right and left arrow keys, ( → , ← ). Using SHIFT  with the
arrow keys moves the cursor quickly to the left or right. The cursor can be
moved to the beginning of the signal display by pressing HOME , and to the end
of the display by pressing END . The right and left arrow keys can also be used
to move to a command in a Menu or List box. Then, press  (or ENTER ) to
select the item.

� Word-by-Word Cursor Moves: The up and down arrows ( ↑ , ↓ ) cause
the cursor to jump from word to word.

� Selection: Make or adjust the size of a selection with the right and left arrow
keys ( → , ← ) while holding down SHIFT .

� Unselect: To Unselect, press DEL .

� Scroll: When the cursor reaches the left or right edge of the screen, the
display scrolls along the signal so that hidden portions appear.

� Zoom: The PG DN  key Zooms In (magnifies) the signal display along the
X-axis, while PG UP  Zooms Out along the X-axis. Likewise, �  Zooms In
along the Y-axis, while �  Zooms Out along the Y-axis. The INSERT  key
centers the Y-axis on the current cursor position.

� Controls Selection: Move between Controls using TAB .

� Windows Selection: Press CONTROL  + TAB  simultaneously to move be-
tween WINSDS and other Windows programs.

� Topmost Window Selection: Use F2  to view the topmost window. To
switch back to the current window, press F2  again. If several topmost
windows are displayed simultaneously, pressing F2  displays each
topmost window before switching back to the current window.
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Hardware and Software Requirements

This chapter is intended to help you to install and run WINSDS software.
Please read the instructions carefully, and make sure the following minimum
hardware and software requirements are met.
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2.1 Description of the WINSDS Package

The WINSDS package consists of the following hardware and software:

� Hardware: DSP board for word analysis and synthesis.

� Software: Three programs for vocabulary generation are included:

� WINSDS software, running under WINDOWS 3.1x or WINDOWS95

� ROMSDS software for synthesizer-chip vocabulary generation

� Sound Editor program to analyze signals and create sound effects

2.2 Hardware and Software

WINSDS requires the following minimum hardware and software:

� PC 486 SX 25 or Pentium (Use of a PC 386 results in very slow display
times.)

� 251-MB Hard Disk Drivespace (2 MB for the program, 20 MB for virtual
memory and applications)

� 8-MB RAM for WFW 3.11 (Less than 8 MB results in the generation of er-
rors.)

� 16-MB RAM (Less than 8 MB results in the generation of errors.)

� 14� VGA color monitor

� 800 x 640 display (Smaller displays result in screen data loss.)

� 3-1/2� floppy (1.44-MB) drive

� Compatible Microsoft Mouse with Mouse interface

� DOS version 6.0 or higher

� MS Windows version 3.1 (or more recent) or Windows95

� WINSDS synthesizer board (The board must be present to operate
WINSDS software fully. However, partial operation is possible without the
synthesizer board.)

� WINSDS Setup diskettes
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3.1 Hardware Installation

The default address for the WINSDS board is 300h. To change this address,
execute the following instructions.

The WINSDS board is seen by the PC as four consecutive 16-bit registers in
the I/O address area. These registers allow the PC to communicate with the
TMS 320C31 chip and to control the synthesis modules directly.

The base addresses of these registers can be selected by changing the
position of the SWI configuration switches located near the PC board
connector (see Figure 3–1).

Figure 3–1. Base Address Registers

Base Address Address Range S1 configuration

300h 300h – 307h

308h 308h – 30Fh

310h 310h – 317h

318h 318h – 31Fh
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3.1.1 Check I/O Address in WINSDS

The WINSDS attempts to locate the WINSDS board at the default location. If
no board is detected at the currently used address, WINSDS displays an error
message and Hardware Configuration Setup window (See Figure 3–2). The
user may try to find the board at another location or use the Auto Detect button
for a Plug-n-Play board search.

Figure 3–2. Hardware Configuration Window

3.2 Software Installation

To install the WINSDS software, first get into Windows 3.1 Program Manager,
Windows95 My Computer, or Windows Explorer. Then insert the WINSDS Set-
up Disk 1 in drive A. Go to the File Menu, click on Run, and type in the following
command on the Command Line:

 A:\SETUP (Press ENTER )

The Setup program then asks for a directory for the WINSDS program. The
default is C:\WINSDS. You may replace the default choice and select your own
drive and subdirectory. The Setup program then transfers and decompresses
the files required to run WINSDS to the designated directory. Follow the
directions on the screen. You are then prompted for additional information
concerning the board address. The default choice is 300h (see Figure 3–1 to
match your address to your board). When you see the WINSDS message,
Please insert WINSDS Setup Disk 2, remove Disk 1 from drive A, insert Disk
2, and click on OK.

The Setup program creates a new group of programs in WINDOWS Program
Manager or Explorer called WINSDS. Eject Setup Disk 2 from drive A, and
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WINSDS installation is complete. If you have problems installing WINSDS,
see Chapter 11: Troubleshooting for help.

3.3 Audio Connections

3.3.1 Hardware

After the WINSDS board has been installed, you should see four jacks on the
back of the computer case. If you are facing the back of the computer case,
the first jack on the left is Phones Output, the second is Line Output, the third
is Line Input, and the fourth or right-most is Microphone Input (see Figure 3–3).

Figure 3–3. WINSDS Motherboard

Microphone Input

Line Input

Line Output

Headphone Output

Synthesis Serial Bus
(for module n� 3)

S1J5

Module n� 0 Location

Synthesis Serial
Bus Connector
(for module n� 2)

Synthesis Serial
Bus Connector
(for module n� 1)

Note:

No cables are included with the WINSDS; they must be purchased
separately. You need to have the following connectors: A male RCA plug at
one end of the cable and a female telephone plug at the other end.
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Figure 3–4. Male Telephone (left) and RCA (right) Plugs

Plastic or Metal Sleeve
to Cover Terminals

Shield
Ground

“HOT”

Tip: Hot

Sleeve: Hot

Solder
Terminals

3.3.2 WINSDS Input/Output Settings

Output Settings

Go to the Setup Menu, and click on Audio Setup. Then click on either Select
Phones Output or Select Line Output, depending on your output jack
connection.

Input Settings

Go to the Setup Menu, and click on Recording Setup. Then click on either Se-
lect Line Input or Select Microphone Input depending on your input jack con-
nection.
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4.1 Start-Up

To start WINSDS, go to Windows Program Manager and click on the WINSDS

icon  in the WINSDS window. As WINSDS is loading, the Texas
Instruments logo appears on the screen. A Welcome to WINSDS message ap-
pears on the screen, followed by a WINSDS Manager message, WINSDS
memory reservation. An Application Status box flashes on the screen, then
changes into an icon in the lower left corner of the screen.

You may want to check the SDS board response to make sure that your
WINSDS board is working. The Application Status box can be viewed by

clicking on the Application Status icon  or by going to the View Menu,
clicking on View Status, and then selecting View Application Status.
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Figure 4–1. Application Status Box

You may also want to check the amount of memory available by looking at
Available Duration (s).
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Note:

1) The Application Status box does not appear the first time you start up
WINSDS.

2) When WINSDS is started, a prompt may ask you if you would like to Edit
a List. The message occurs if there is a check before Invite to edit list at
start-up in the Start-up submenu of the Options Menu of the Setup Menu.
If you do not want the message to appear, click on the item, and the
check mark disappears. The next time WINSDS starts, the message will
not appear.

Likewise, if the Record Light icon        on the Toolbar flashes red upon
start-up, then the Invite to record at start-up option in the Start-up subme-
nu of the Options Menu of the Setup Menu is checked. If you do not want
to begin recording automatically upon start-up, click on the command,
Invite to record at start-up. The check mark disappears, and the next
time WINSDS is started, recording does not begin automatically.

3) Upon start-up, a message may appear, Do you want to open current
application [filename]? This occurs if an application was saved at the end
of the previous work session. (See the following text for information on
applications; also Section 8.1; Saving Your Work.) If you do want to get
into the previous application, click on Yes. If you do not want to get into
the previous application, click on No. Then you may create a new
application or open an existing application (See Sections 4.2 and 4.5 for
details).

4.1.1 Change Memory Settings

Before you create a new application or open an application, go to the Setup
Menu, Options submenu, and click on Change WINSDS memory settings. It
is important to allocate enough memory for WINSDS to run correctly. A low
amount of memory results in erratic errors.

4.1.2 Colors Setup

Before creating or opening an application, you may want to change the display
colors for your WINSDS workstation. Go to the Setup Menu and click on
Colors. A Colors Setup window appears as shown in Figure 4–2.
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Figure 4–2. Colors Setup Window

The Colors Setup window allows you to choose colors for displays including
the Signal, Cursor, Grid, Curve (e.g., Signal Display area) and Text
Backgrounds, Curve (e.g., Signal Display area) Text, and Ruler Bar. You may
also change the color of a chosen Signal Number. Click on a color box for a
given display (e.g., Signal, Cursor) and a Color box appears. Choose a color
from Basic Colors, Custom Colors, or Define Custom Colors options. Click on
Update, Cancel, or OK.

4.2 Creating a New Application

4.2.1 Parameter Settings

To create a new application, go to the File Menu and click on New Application.
A New Application Setup window appears displaying five parameters as
shown in Figure 4–3.

Note:

These parameters are defined at the Application or Word level, and are
assigned default values depending on the type of chip and decoding table
used. Application-level values apply when no other values are defined at the
Word level. Application-level values are stored in a Parameter Description
file, while Word-level values are stored in a Word Access file.
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� Analysis Method [METHOD]: You may choose LPC10, LPC12, or MELP. The default method is
LPC10.

� Synthesizer Chip [CHIP]: This mandatory parameter determines the type of synthesizer chip. It
sends chip-related, non-modifiable parameters (or default values) to the synthesizer board.
Choose the type of chip you plan to use for synthesis (MSP50C1x or MSP50C3x). The default is
MSP50C1x. (MELP and dual-channel analysis require MSP50C3x.)

� Coding Scheme [TABLE]: Select a coding table (654P74 is the default). Only the standard coding
scheme is currently available for MELP.

� Sample Frequency [FREQ]: Select 8 kHz or 10 kHz. A sampling rate of 8 kHz is usually good for
low-pitched male voices, while 10 kHz is good for higher-pitched female, child, and character
voices.

Note:

A Frame is the period of time characterized by a fixed number of samples.
A sample (or point) is the smallest quantity of digitized sound represented
by a fixed level and determined by the Sampling rate, e. g., 8 kHz or 10 kHz.)

� Frame Duration [NFRAME]: For LPC analysis, select a Frame duration (in Samples) from 40–200.
You may also type in a user-defined value within that range. Default value = 200. For MELP analy-
sis, there are two choices: 201 and 150. Default value = 201.

� Frame Duration: indicates the number of samples between the new LPC parameter computations.
The shorter the frame duration, the more precisely the speech is coded, and the higher the data
rate is. A frame duration of 100 is shorter than a frame duration of 200.

Figure 4–3.  New Application Setup Box
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When you have finished selecting parameters, click on OK. WINSDS
Application Setup calculates and generates a new database for your
Application and initializes the Analog Board (if present).

4.2.2 Template

Clicking on the Template button in the New Application Setup window opens
the Select WINSDS Application window. Select an Application with the
parameter settings that you would like your New Application to copy. The
values for sampling frequency, frame duration, chip and coding table are taken
from the template Application and given as current values for the New
Application.

Note:

For New Application, the settings are default settings. To return to the default
settings after selecting a template, use the Cancel button and redo the
command.

View Status in the View Menu allows you to View Application Status (or View
Word Status) at any time during a work session. An Application Status window
shows the analysis parameters for the Application and other information
relevant to the Application. Change parameter values by clicking on a value
for other choices or by typing in a new value (see Figure 4–1).

4.3 Setups

WINSDS has several precustomized Setup files that work well for most users.
However, you may want to modify a parameter or parameters for a particular
application. For example, you may want a sampling rate of 8 kHz instead of
10 kHz, etc.

� Application Setup: The Application Setup allows you to set or view station
parameters. You can change the defaults provided by the analysis method
for a given Application. Changes are stored at the Application level.

� Recording Setup: You can choose from Line or Microphone Input and
adjust Input Gain or Recording parameters. If a Recording parameter is
changed, it is saved with the Application when the Application is saved.

� Audio Setup: Choose Line Output or Phones Output, and adjust Output
Gain levels to 0 dB.

Each of these Setups is discussed in detail in the appropriate section (i.e.,
Section 4.4, Application Setup; Section 5.3, Recording Process; and Section
5.1, Playing a Signal).
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4.4 Application Setup

The Application Setup command in the Setup Menu displays a Station
Configuration window containing information about WINSDS parameter
settings as shown in Figure 4–4. Defaults are provided by the Analysis Method
(LPC10, LPC12, or MELP). Settings for most Analysis Parameters can be
changed by selecting or typing in other values. Settings for the first five
parameters, however, cannot be altered. These parameters are described in
Section 4.2, Creating a New Application.

Figure 4–4. Station Configuration Window

Each of the WINSDS parameter settings displayed in the Station
Configuration window is discussed in the following text. Parameter labels are
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listed in square brackets. (Please note that the first five parameters listed in
the Station Configuration window are discussed in Section 4.2, Creating a New
Application.)

Alterable Analysis Parameters:

� Voiced Speech Analysis Window Size (%) [LPCV]: This parameter is
expressed as a percentage of the frame duration. The LPCV% value is
calculated as percent of the number of samples divided by 100; the result
cannot exceed 400. That is, the range of permissible values is 100–300%
of the number of samples. The minimum value is 100%. The maximum
LPCV% value is 300% or the value that corresponds to 400 samples.
Default = 150%.

� Unvoiced Speech Analysis Window Size (%) [LPCU]: Like [LPCV], this pa-
rameter is expressed as a percentage of the frame duration. The LPCU%
value is calculated as percent of the number of samples divided by 100;
the result cannot exceed 400. That is, the range of permissible values is
100–300% of the number of samples. The minimum value is 100%. The
maximum LPCU% value is 300% or the value that corresponds to 400
samples. Default = 100%.

� Minimum expected Pitch period (estim.) (ms) [T0MIN]: This parameter
should be adjusted to the pitch of the voice to be analyzed. Low values
should be used for special effects where great precision of measurement
is not the main goal. [T0MIN] is expressed in milliseconds (ms). Accept-
able values range from 1.00 ms to the [T0MAX] value (see the following
test). Default = 1.

� Maximum expected Pitch period (est.) (ms) [T0MAX]: The [T0MAX]
parameter should be adjusted to the pitch of the voice to be analyzed. High
values work best for low-pitched voices, while low values work best for
high-pitched voices. [T0MAX] is expressed in milliseconds (ms). The
following are acceptable values:

8 kHz sampling frequency: 1.00 = 18.75 ms

10 kHz sampling frequency: 1.00 = 15.00 ms

� Maximum expected Pitch change between 2 frames (%) [T0VAR]:
Represents the maximum expected pitch change between two frames
during precise evaluation operations. It is expressed as a percentage of
the pitch duration. Values range from 0 –100%, with default values of 10%
and 50%. This parameter is fundamental to pitch computation, and it is
used for Calculate Pitch and for Calculate Pitch Step-by-step commands
(see Section 6.4, Modify Commands). Default = 10%.
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� Voiced Analysis Ponderation (Hamming) window [HAMV]: Flag indicating
if a Hamming window weighting must be applied to LPC analysis of Voiced
Frames. Typical value = TRUE.

� Unvoiced Analysis Ponderation (Hamming) window [HAMU]: Flag
indicating if a Hamming window weighting must be applied to LPC
analysis of Unvoiced Frames. Typical value = TRUE.

� LPC signal Zero Output (dB) [LPCLEV]: Acceptable values range from
–60 dB to –20 dB. Default value = –60 dB.

� Voiced Analysis Pre-emphasis factor [EMPHV]: Represents a
high-frequency pre-emphasis factor for Voiced Frames. This parameter is
expressed as a percentage, with acceptable values ranging from 0–100%.
Default value = 0.

� Unvoiced Analysis Pre-emphasis factor [EMPHU]: Represents a
high-frequency pre-emphasis factor for Unvoiced Frames. This
parameter is expressed as a percentage, with acceptable values ranging
from 0 –100%. Default value = 0.

� Energy of Voiced pick-up (excitation) function [KEXIV]: The multiplicative
coefficient to be applied to the Voiced excitation function. This parameter
represents the Energy of the pick-up function, which in turn, represents the
signal generated by the vocal folds exciting the vocal tract. Acceptable val-
ues range from 0 – 7.99. Low values are used for higher voiced excitation,
and high values are used for lower voiced excitation. Default value is 1.62.

� Energy of Unvoiced pick-up (excitation) function [KEXIU]: The
multiplicative coefficient to be applied to the Unvoiced excitation function.
This parameter represents the Energy of pick-up function, which in turn,
represents the noise generator for Unvoiced sounds exciting the vocal
tract. Acceptable values range from 0 – 7.99. Low values are used for
higher Unvoiced excitation, and high values are used for lower Unvoiced
excitation. Default value is 0.64.

� Multiplicative coefficient for synthesized signal [KSIG0]: Acceptable
values range from 0.5 – 1.0. Typical value = 1.0.

� Nb (Number) reflection factors in Voiced portions [NKIV]: Number of
reflection coefficients (K-parameters) applied to Voiced Frames. Default
value is 10 for LPC10 and 12 for LPC12 and MELP.

� Nb (Number) reflection factors in Unvoiced portions [NKIU]: Number of
reflection coefficients (K-parameters) applied to Unvoiced Frames.
Default value is 4 for LPC10 and 6 for LPC12.
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4.5 Opening an Existing Application

To open a previously saved application, click on Open Application in the File
Menu. A window containing a directory of stored applications appears. Click
on the disk drive containing the application that you wish to use.

Select the correct application by double-clicking on the Path Directory in the
left window. For additional help in locating your application, you may
double-click on a root directory and then on Auto. This function searches for
applications in every subdirectory of the root directory. The cursor becomes
an hourglass icon, and results appear in the right-hand window. You may stop
the process at any time by clicking on Cancel.

Select an Application by clicking once on the name of the application in the
Results window, or by double-clicking on the application name in the Path
Directory in the left-hand window. When the Current Word File (filename.wrd)
corresponding to the selected application appears in green in the middle
window, click on OK to confirm your selection (see Figure 4–5).

Figure 4–5. Select WINSDS Application Box
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4.6 Word Setup

Once an application has been opened and a word has been displayed using

the Read a Word command in the File Menu (or the Read-a-Word icon 
on the Toolbar), the Word Setup command in the Setup Menu can be used to
show parameters that can be altered for reanalysis of the word. The Word
Setup window (Word Alterable Analyze Parameters window) is shown in
Figure 4–6.

Note:

The parameters are the same as those obtained using the Application Setup
command in the Setup Menu. The parameter values can be changed by
clicking on the value to be modified and then either by choosing a value
provided in the drop-down menu or by typing in the desired value within the
range specified.
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Figure 4–6. Word Alterable Analyze Parameters Window
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Inputting, Playing, and Viewing Signals

Once an application is created or opened, you can:

� Play words in an open application
� Import words to a new or open application
� Record new signals to a new or open application

Topic Page

5.1 Playing a Signal 5-2

5.2 Importing a WINSDS or a SDS5000 Word 5-6

5.3 Recording Process 5-8

5.4 Viewing Signals 5-15

5.5 Viewing Options 5-20
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5.1 Playing a Signal

5.1.1 Select Output

Go to the Setup Menu, click on Audio Setup, and then choose either Select
Phones Output if you want to hear the signal through headphones or Select
Line Output if you want to hear the signal through a speaker.

5.1.2 Adjust Output Levels

Before trying to listen to a signal, go to the Setup Menu and click on Audio
Setup. In the submenu, click on Adjust Output Settings, and a Play Output
Settings window displays Phones Output Gain and Line Output Gain meters,
which range from –45 dB to 0 dB. Use the scroll bars to adjust each output gain
level.

Figure 5–1. Play Output Settings Window
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5.1.3 Play

Next, be sure that the signal is displayed on the screen. (If there is no signal,
go to the Edit Menu and select Read a Word, or click on the Read a Word icon

on the Toolbar , or select Read a Word on the Word Database box). Next,
go to the Play Menu or use the Play Pad (by clicking on Slow Play and Play

Pad in the Play Menu, or by clicking on the Play Pad icon  , or on the Play

icon  on the Toolbar.

Play Options:

� Play Original Signal: Plays the Original sound wave with no synthesis.

� Play Uncoded Synthetic: Plays the Uncoded Synthetic sound resulting
from LPC analysis, which is usually better quality than Coded Synthetic
speech.

� Play Coded Synthetic: Plays the Coded Synthetic sound.

� Play Compressed Synthetic: Plays synthetic speech to which a
user-defined compression rate has been applied.

For each Play option, you can listen to the:

� Entire Signal by choosing Play Channel (All)

� Word by choosing Play Word

� Selection by choosing Play Selection

� Single Frame by choosing Play Current Frame

There are two options only available for Synthetic Speech:

� Slow Play: Use the Play Pad from Slow Play and Play Pad in the Play
Menu to make the speech rate faster or slower. Sliding the button along
the slow-fast scroll bar changes the rate of speech as a percentage (25%
= fastest rate, 100% = original rate, and 400% = slowest rate), which
appears to the right of the scroll bar.
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Figure 5–2. Play Pad

� Play a Single Frame: Causes the frame to be repeated continuously. A
Play Single Frame window allows you to choose to listen to the Next
Frame or Previous Frame by clicking on the desired option. The cursor
position changes automatically to the selected frame. Click on Cancel to
stop Play Single Frame.

Figure 5–3. Play Single Frame Window

You may also listen to the sound to the left or right of the cursor. These choices
are listed in a submenu for each Play Option and on the Play Pad.
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5.1.4 Stop Play

To stop Synthesis, click on one of the following options:

� Stop icon  on the Play Pad or on the Main Menu Toolbar

� Stop Play ( F6 ) in the Play Menu

5.1.5 Repeat Play

To repeat the last played sequence, click on one of the following:

� Play icon  on the Main Menu Toolbar

� Repeat Play command in the Play Menu

5.1.6 Play Split Aux Frame Toggle ( CONTROL  + A )

When a frame is split into two parts, this command replaces the first part of the
frame with the second part of the frame. The word is played with the second
part of the frame.

5.1.7 Play Both Channels ( CONTROL  + B )

This feature works when an application is initialized for the 3x chip. Click Play
Both Channels in the Play Menu or use the keyboard command ( CONTROL  +

B ) to listen to a word displayed on Channel 1 and a word displayed on
Channel 2 simultaneously.
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5.2 Importing a WINSDS or a SDS5000 Word 

To import a WINSDS word, press CONTROL + W . To import a SDS5000 word,
press CONTROL + D . Words and their associated signals may be imported from
either WINSDS or the SDS5000. A word is defined as the basic unit of the
WINSDS station. A word has a label, a comment zone, and at least three
associated signal files:

� Original Signal (Wordname.sig)
� LPC Analysis Results (Wordname.prm)
� Coded and Compressed Bitstreams (Wordname.bin)

Note:

A given word may have several versions of LPC analysis results and coded
bitstreams.

5.2.1 To Import Words From SDS5000 or WINSDS Files

Go to the Edit Menu and click on Import an SDS5000 Document or Import a
WINSDS Word. A window with a directory of applications/documents appears
as in Figure 5–4:

Figure 5–4. Open WINSDS Application Window
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Note:

You may return to the directory at any time during a work session to scan
directories of stored applications and documents by clicking on View
Directory in the View Menu.

If you know the Application Name: Select the disk drive containing your ap-
plication. Then, scroll through the list in the left-hand window until you see the
application (or its subdirectory). Double-click on your application, and the
name of the word access file appears in green in the middle window. Click on
OK.

If you don’t know the Application Name: Select the disk drive (e. g., C:, D:)
where you think it is located. Then select the correct path by double-clicking
on the root directory and Auto. This function searches for your application in
every subdirectory of the root directory. The cursor becomes an hourglass
icon, and results appear in the right-hand window. You may stop the process
at any time by clicking on Cancel.

When the application is found, select it by clicking once on its name in the
Results window, or by double-clicking on the application name in the directory
in the left-hand window. When the word access file (filename.wrd)
corresponding to the selected application appears in green in the middle
window, click on OK to confirm your selection or double-click on the word
name.

A Select Word box opens. To select, highlight the word(s) you wish to import
or click on Select All to import all words in the application. Use the Read a Word
option to display the signals for a given word; then play the displayed signal.
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5.3 Recording Process

If you usually record at start-up of the WINSDS, and you want to begin
recording automatically, go to the Options submenu of the Setup Menu. Click
on Startup and then on Invite to record at startup. A check mark appears in
front of the command, and the next time WINSDS is started, the Record icon
begins flashing red, indicating that the recording process has started automati-
cally. However, if you do not want to record automatically at startup, make sure
that no check mark appears in front of Invite to record at start-up.

5.3.1 Select Input

In the Setup Menu, click on Recording Setup and then on Select Line Input if
you are recording from an audio-tape or CD. Click on Select Micro Input if you
are recording from a microphone.

5.3.2 Adjust Input Gain

Go to the Setup Menu, click on Recording Setup, and then on Adjust Input Gain
level. The Record Input Settings window appears. To adjust input level, reset
the maximum level indicator by clicking on Reset. Input the signal. If the input
level is too high, the Saturation light turns red. Click on Reset to reset the
maximum input level indicator. Make any necessary adjustments in the input
gain level by using the scroll bar.

Figure 5–5. Record Input Settings Window
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5.3.3 Recording Parameters

Keep in mind that the [ENDWRD] parameter must always be ≥ [BFRSIG] +
[AFRSIG].

Figure 5–6. Recording Parameters Window

Recording Parameters

� Speech Signal Threshold Detection (dB) [SIGLEV]: WINSDS only records
speech if the energy level of a signal is greater than the SIGLEV value.
Acceptable values range from –60 to –20 dB. Default value = –60 dB.

� End of Sentence Duration (ms) [ENDSEN]: Duration of silence required
for the recording process to stop. That is, WINSDS stops recording silence
if it detects silence longer than the ENDSEN value. Acceptable values
range from 0 – 30 s. Default value = 10,000 ms.

� Once a signal has been recorded, WINSDS automatically edits the signal
to delete excess silence at the beginning and end of the signal:

� Time before Speech start (ms) [BFRSIG]: Maximum signal duration
allowed as lead time before the beginning of a word is detected. Ac-
ceptable values range from 0 – 800 ms. Default value = 300 ms.

� Time after Speech end (ms) [AFRSIG]: Maximum signal duration
allowed as lag time after the end of a word is detected. Acceptable
values range from 0 – 800 ms. Default value = 400 ms.
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� End of Word Duration (ms) [ENDWRD]: When recording in Word-by-
Word mode, WINSDS automatically detects word boundaries. End of
Word Duration is the duration of silence required for a word boundary
to be detected. Acceptable values range from 0 s – 30 s. Default value
= 700 ms.

Recording Options

� Acquisition with Analysis: If checked, the recording process includes LPC
parameter analysis. If you record a signal and R but no A appears in the
Read a Word box, check if this option has been selected; if not, select it.

� Analysis includes Pitch: If checked while recording or with off-line analysis,
pitch calculation is included in LPC analysis. This feature should be
checked.

5.3.4 Recording A Signal

Go to the Record Menu and choose from four Record modes:

� Record One Word

� Record in Word-by-Word Mode

� Record in Phrase Mode

� Record Words with Playback

Record One Word: The basic recording mode. LPC and pitch analyses are

done simultaneously. To record a new word, click on the Record icon  or on
Record One Word in the Record Menu.

A red-light icon on the Toolbar  begins to flash to signal when recording
begins. When the speaker begins to talk, the red-light icon stops flashing and
remains solid red during recording. If saturation occurs during recording, the
red-light icon flickers. It shuts off (turns to gray) when recording ends.

To erase the displayed signal from the screen, go to the Window Menu and
click on Reset Signals and then on OK to Confirm signal window reset on
channel. However, a displayed signal does not have to be erased from the
screen in order to read another Document.

Record Word-by-Word Mode: This mode automatically puts breaks between
words, i.e., where silence is detected.

Record in Phrase (or Sentence) Mode: This mode causes the whole signal to
be recorded without breaks until a sufficiently long silence is detected.



Recording Process

5-11Inputting, Playing, and Viewing Signals

Record Words with Playback Mode: This mode works like Record
Word-by-Word, but after each word has been pronounced by the speaker, it
is played back so that the user can check the sound quality. F6

Note:

In this mode, the recording process must be stopped manually by clicking on
the Stop icon on the Toolbar or on the Stop Play command [F6] in the Play
Menu.

Stopping The Recording Process: It is possible to stop the recording process
at any time by using one of the following options:

� Click on Stop Play ( F6 ) in the Play Menu.

� Click on the Stop button  on the Toolbar or Play Pad.

� Wait for the End of Sentence Duration message indicating that [ENDSEN]
has applied. (See Setup: Recording Setup: Recording Parameters for
more details.)

5.3.5 Labeling and Analyzing Signals

� Edit Label and Comment

� Apply Scenario

� Analyze Word

� Analyze Selection

� View Word Status

Labeling A Word: When LPC and pitch analyses are completed, the signal and
LPC parameters appear on the screen. As shown previously, you can label the

recorded word by clicking on the Label Word icon  on the Toolbar, or click
on Edit Label and Comment in the Edit Menu. An Edit Word window appears
with space for a 32 character word label and an 80 character comment. (See
Figure 5–7.)

Naming a word with the label of a previously recorded word is not permitted.
You can make changes to the label or comment at any time. To confirm the
word label, click on Update or OK in the Edit Word Label window. Update
leaves the Edit Word Label on the screen as a topmost window in front of all
other windows in order to accelerate the labeling process. The Edit Word Label
window can also be minimized.
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Apply Scenario Command: Apply Scenario automatically labels words
recorded using Record Word by Word. Word labels come from a previously
created list. (See Chapter 7,Lists, for more information.)

Figure 5–7. Edit Word Label Window

Analyze Word: Re-analyzes a word chosen from a list. The Word List can be
used to re-analyze several words at a time. The Word Status Table shows the
status of the words in the application.

Note:

MELP analysis is not automatic for Words imported from another application.
They must be re-analyzed.

Analyze Selection: Re-analyzes a selection highlighted on the signal display.

The View Word Status box in View Status of the View Menu displays a window
containing information regarding the status of a specific word as shown in
Figure 5–8. This information is useful during the Compression process.
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Figure 5–8.  Word Status Window

View Database Word Table: This feature sorts words in the application into
subsets according to the option(s) selected in the lower part of the window:

� Unrecorded

� Unanalyzed

� Uncoded

� All Words

� Sorted

� Strict Condition

Information may be displayed either by word number (01, 02, etc.) or by label
and version. All Words displays all words in the application. The Strict Condi-
tion causes the various options (listed previously) to be exclusive of one
another. For example, if Unrecorded is checked, but Unanalyzed and
Uncoded are not checked, in the Strict Condition all words are displayed that
are unrecorded (no Original sound samples) but have LPC analysis
parameters and binary coded files. Not checking the Strict Condition option re-
sults in all unrecorded words being displayed.

In the View Database Word Table, words in the application appear in one list,
and the current status of the words appears in a second list as:
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R: Recorded

A: Analyzed

S: There is a binary file saved on disk for the Word.

If the two lists are not in synch, they can be synchronized by clicking on an item
in one of the lists.

Figure 5–9. View Database Word Table
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5.4 Viewing Signals

To view a signal, go to the Edit Menu, click on Edit Signal Channel 1 or Edit
Signal Channel 2, and then on Read a Word in the submenu. You can also view

a signal by clicking on the Read a Word icon  on the Toolbar.

Clicking on the Read a Word icon causes the Read a Word window to appear.
Double-click to highlight the word you want to display. If you want to display
more than one word, use the Add a Word command. To clear the display, use
the Reset Signals/Clipboard command in the Window Menu.

As shown in Figure 5–10, three windows appear, displaying the:

� Signal

� Pitch Contour

� Energy Contour

Figure 5–10. View Signal
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5.4.1 View Signal

This command displays the Original signal in the Channel 1 or Channel 2
window along with two other analysis parameters. Defaults are Pitch and
Energy.

5.4.2 View Pitch

This command acts as a toggle checkbox. As mentioned previously, the
Original signal is displayed in the Channel 1 or Channel 2 window along with
two other analysis parameters. Defaults are Pitch and Energy. When other
parameters are viewed, they first replace Energy, then Pitch. Use this
command to display the pitch curve again.

5.4.3 View Energy

Like View Pitch, this command acts as a toggle checkbox. The Original Signal
is displayed in the Channel 1 or Channel 2 window along with two other
analysis parameters. Defaults are Pitch and Energy. When other parameters
are viewed, they first replace Energy, then Pitch. Use this command to display
the energy curve again.

5.4.4 View Other Parameters

This command displays other analysis parameters besides Pitch and Energy
as shown in Figure 5–11. Frame Threshold is considered a parameter like the
others and can be displayed as a signal.

For LPC10 analysis, the parameters are listed in the Choose Parameter box.
There are 10 voiced Ki parameters, 4 unvoiced Ki parameters, and 1 specific
parameter: Frame Threshold for LPC10.
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Figure 5–11.Choose Parameter Box

Note:

The drag and drop mouse operation may be used to drop and replace a
parameter in a parameter display. Select the parameter from the drop-down-
list box on the Toolbar shown in Figure 5–12. Drag the parameter to the
desired display and drop it. Be sure that the left-most icon on the Parameter
Toolbar is selected for View Parameter.
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Figure 5–12. Signal Drop-Down List Box

5.4.5 Add Parameter

This command is used to add a parameter for a multiple signal display. Select
one of the 2 parameter display areas by clicking on one of them or on the title
region. The selected curve is outlined by a thin border. Select the Add Signal
Channel command for the desired channel. WINSDS asks you to choose a pa-
rameter. The selected parameter is added to any previously displayed
parameter curves in the display. The limit is 16 parameters per display.

Note:

The drag and drop mouse operation may be used to drop and replace a
parameter in a parameter display. Select the parameter from the
drop-down-box on the Toolbar (See Figure 5–12). Drag the parameter to the
desired display and drop it. Be sure that the middle icon on the Parameter
Toolbar is selected for Add Parameter.

5.4.6 Select Parameter

This command in the View Menu is used to select a parameter in a multi-signal
display. This is useful to determine the Y-axis value of a parameter at the
current cursor position. Note that the current parameter color becomes the text
color in multiple signal display. (For more information, see the section on the
Colors option of the Setup Menu.)
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To use this command, first select one of the parameter displays (Pitch or
Energy) by clicking on it or on the title bar. The selected display is outlined by
a thin border. Select the Select Signal Channel command for the desired
channel. WINSDS asks you to choose a parameter. The selected parameter
becomes the current parameter in the curve.

Note:

A parameter may be selected as the current parameter directly from the Tool-
bar. Select a parameter display area (i.e., Pitch or Energy) by clicking on it
or on the Title bar. The selected display area is outlined by a thin border. Se-
lect the parameter from the drop-down-list box on the Toolbar. (See
Figure 5–12.) Be sure that the right-most icon in the Parameter Toolbar is
selected for Select Current Parameter. 
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5.5 Viewing Options

Dual-Channel Simultaneous Display: To display both channel signals as
shown in Figure 5–13, go to the Edit Menu and click on Edit Signals. Next, tile
(arrange) both signal windows side-by-side by clicking on Tile Forms Vertical
in the Window Menu.

Figure 5–13. Dual-Channel Display

Word Selection: When more than one word is displayed, one of the words may
be selected (highlighted) by double-clicking on the word signal as shown in
Figure 5–14:
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Figure 5–14. Selecting a Word

Cursor: The cursor is moved either by clicking on the display or by using the
right and left arrow keys ([←][ →]). Use the up and down arrow keys ([↑ ][↓ ])
to move the cursor from word to word.

Scrolling: Scroll to the right or left of the current screen by moving the cursor
to the right or left border of the screen.

Zooming: You can zoom in or zoom out on the x-axis or y-axis when viewing
signals by using the mouse to select a portion of the signal. Zoom In/Zoom In
Y Axis magnifies that portion of the signal display in stages so that it can be
viewed more closely. You can click on the appropriate Zoom-In icon on the

Toolbar   . Zoom Out/Zoom Out Y-Axis returns the signal back to its

original size in steps. You can also click on the appropriate Zoom-Out icon 

 on the Toolbar. If you prefer, click on Zoom In or Zoom Out commands in
the View Menu.
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Figure 5–15. Zoom
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6.1 Select/Unselect

Selecting Part Of A Signal: Using the mouse, select the part of the signal you
wish to cut or copy and paste by pressing the (right) mouse button and
dragging the cursor across it. Release mouse button to end selection. You can
also click on Select in the Edit Menu or use DELETE . The selected part is high-
lighted. To change the selected part of the signal, hold down SHIFT  and move
the cursor to the new endpoints. (See Figure 5–10 for Selection display.)

Unselect DELETE : To Unselect a previously selected part of the signal, click
on Unselect in the Edit Menu or press DELETE .

6.2 Cut, Copy, and Paste Selection

6.2.1 Cut and Copy

These commands allow you to delete, transfer, or duplicate a set of Frames
in a word. If the selected part of the signal includes a given word, then the word
is viewed by WINSDS as a set of frames in the word. The set of frames can
be cut or copied to a clipboard. If a given word occurs more than once in a list,
the Cut command acts on all occurrences of the word.

If the selected part of a signal extends across the signals for two words in a
list, the selection extends to all words included in the selection. This is
equivalent to manipulating the Object List (see Chapter 7, Lists). List words
may be locally transferred or copied.

� Cut Selection: To delete a selected portion of the signal, press CONTROL

+ X , or go to the Edit Menu and click on Cut Selection.

� Split Current Word: The Split Current Word command is another way to
cut out part of a signal. Position the cursor where you want to make a cut.
Either go to the Edit Menu, click on Miscellaneous, and then on Split
Current Word in the submenu, or press F3 . The cut shows up as a vertical
green line on the Scale bar underneath the signal display window as
shown in Figure 6–1.

Figure 6–1. Split Current Word

� Label Word: Label each new word using Edit Label and Comment

command in the Edit Menu or click on the Edit Label icon  on the
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Toolbar. The name of the word in which the cursor is currently positioned
appears in the lower left corner of the screen (see Section 5.3.5, Labeling
and Analyzing Signals, and Section 6.4, Modify Commands, for more in-
formation).

� Delete Word: There are two ways to delete a word: (1) Click on Delete
Word under Miscellaneous in the Edit Menu or use the ALT  + BACK SPACE

keyboard command; (2) Click on the Delete Word option in the View
Database Word Table window or use the SHIFT  + DELETE  keyboard com-
mand. A list of words appears. Highlight a word to delete it, and click on
OK, and on Yes to confirm your intention to delete the word. Repeat the
process for each word to be deleted (see Section 6.3, Miscellaneous Edit
Commands).

Figure 6–2. Delete a Word
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6.2.2 Paste Selection

Place the cursor where you want to paste a selection and press  CONTROL  + V .
The pasted frames are inserted at the cursor position.

� To Paste Frames to the End of a Word: Select the signal for a word. In the
Edit Menu, click on Edit Signal Channel 1 (or 2) and then on Read a Word
in the submenu. Position the cursor at the end of the signal, and click the
mouse or press → . A message appears to signify End of Sentence. Click
on OK and immediately paste. The pasted frames appear after the last
frame of the word.

Figure 6–3. Paste Frames

6.3 Miscellaneous Edit Commands

The following commands appear in the Miscellaneous submenu of the Edit
Menu.

6.3.1 Transformation Commands

� Delete Word SHIFT  + DELETE : Deletes the word at the current cursor posi-
tion. Highlight the word you wish to delete from the Delete Word window
and click on OK to confirm deletion of the word.

� Insert a Silent Frame CONTROL  + I : Inserts a silent frame at the current
cursor position.

� Exchange Words CONTROL  + E : Replaces one word with another. Place
the cursor on the word you wish to replace. Next, select the word to appear
in its place, by selecting it either in the signal display or in the Read a Word
window. Then click on Exchange Words.

� Mirror Word CONTROL  + O : Reverses the word at the current cursor
position. The word then appears and play backwards.
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Figure 6–4. Mirroring

Before Mirroring:



Miscellaneous Edit Commands

 6-6

After Mirroring:

� Replace Parameter CONTROL  + P : Gives a list of parameters to choose
from (Pitch, Energy, and K-parameters) to replace a parameter in a selec-
tion. First, copy a word frame selection to the Clipboard and drag the
Selection Zone to the Replacement Zone. Then click on Replace Parame-
ter.

6.3.2 Split Commands

� Split Current Word F3 : Splits a word in two at the current cursor position.

� Split Current Frame CONTROL  + F : Splits a frame at the current cursor
position.
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Figure 6–5. Split Current Frame

� Split-show First Frame Toggle CONTROL  + T : Displays the parameters for
the first or second split frame.

� Concatenate Adjacent Words ( F4 ): Place cursor on the green cut line
between the two words and click on Concatenate Adjacent Words under
Miscellaneous in the Edit Menu, or simply press F4 . Rename the word,
if you wish, using Edit Label and Comment in the Edit Menu or the Edit

Label icon  on the Toolbar.

� Concatenate Split Frame CONTROL  + G : Rejoins a previously split frame

6.3.3 Frame Commands

� Repeat Current Frame CONTROL  + R : Repeats the frame at the current
cursor position. Click on the Repeat Current Frame command in the
Miscellaneous submenu of the Edit Menu or use the short-cut CONTROL  +

R  keyboard command. In the box that appears, type in the number of
times that you want the frame to be repeated. Two horizontal green lines

appear on the frame in the Scale bar:   .

� Skip Current Frame (toggle) CONTROL  + K : Skips the current frame during

synthesis.   . Click on the Skip Current Frame command in the
Miscellaneous submenu of the Edit Menu or use the short-cut CONTROL  +

K  command. Clicking on a skipped frame undoes the Skip process.
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� Mark Frame for Reference: Marks a frame for future reference. Use the
Miscellaneous submenu command of the Edit Menu, or the specific icon

 to mark or unmark the current frame. The marked frame appears in

the Scale bar as the symbol   .

6.4 Modify Commands

The commands in the Modify Menu are used to edit parameters. After making
modifications, you can choose to either Cancel Corrections or Make
Corrections Permanent by clicking on these options in the Modify Menu. The
following subgroups of commands are found in the Modify Menu:

� Pitch Commands
� Energy Commands
� Modify Edit Parameters Commands
� Compression Thresholds Commands
� Formant Editing Command

Some Modify commands, including Calculate Pitch Step-by-Step and Alter
Pitch or Energy Curve Slopes, involve the notion of Clusters. A Cluster is a
selection created by moving the cursor from left-to-right (left-origin) or from
right-to-left (right origin).

6.4.1 Pitch Commands

Group 1 :

� Alter Frame Pitch Value: Changes the value of the current frame (where
the cursor is positioned) to a user-defined value. If the frame has a value
of zero, it is Unvoiced.

� Interpolate Pitch CONTROL  + Y : Computes the pitch value of the current
frame or selected frames as a linear interpolation between the value of the
previous frame and the value of the following frame. For example, if the
pitch value of the current frame is 75, the previous frame is 67, and the
following frame is 87, then the interpolated pitch value is 77:
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Figure 6–6. Interpolate Pitch

Linear interpolationPitch

Frames

Interpolate value=77.37

Pitch curve
67

75

87

nn–1 n+1

� Divide Frame Pitch by Two: Cuts the pitch value of the current frame in
half.

� Multiply Frame Pitch by Two: Doubles the pitch value of the current frame.

Group 2 :

� Measure Pitch Value: Measures the pitch value of the current frame. When
you place the cursor on the frame where pitch is to be measured, or click

on the Measure Pitch icon  on the Toolbar, a Measure Pitch window
appears:

Figure 6–7. Measure Pitch Window
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Select a zone between two consecutive peak values. Use the buttons 

to fine-tune the selection. Clicking on the  button causes the maximum
values to be calculated automatically. You can also click on Calculate Pitch in
the Measure Menu at the top of the Measure Pitch window to calculate
maximum pitch values.

To transfer measurement, click on OK or Update, or go to the Measure Menu
at the top of the Measure Pitch window, and click on Transfer Measurement.

Note:

If the Selection Zone spans two different frames or is located in a different
frame than the cursor, a message appears asking for confirmation. Several
frames may be adjusted consecutively without exiting the Measure Pitch
window. Use the cursor or arrow keypad to scroll through the signal.

� Calculate Pitch: Automatically recomputes the pitch value of a given
voiced frame. The current pitch value is re-evaluated in terms of the pitch
values of adjacent frames. The maximum expected pitch change for this
calculation is a user-defined variable (T0VAR), given as a percentage.
(See Application Setup command in Chapter 4.)

� Calculate Pitch Step-by-Step: Automatically recomputes the pitch values
around the corrected one in a selected cluster of frames. The estimated
pitch value is that of the frame preceding the Selected Cluster. As shown
previously, the starting frame for recomputation is the user-defined
variable (T0VAR), given as a percentage. (See Application Setup in
Chapter 4.)

� Alter Pitch Curve Slope CONTROL  + U : Changes the pitch values of a
selected cluster of frames to alter the intonation (melody) of a signal. The
pitch of a given frame is altered by adding a value percentage (Ck) to the
pitch value (Pk) of each voiced frame in a cluster. The value percentage
is calculated as a percentage of the difference between the altered pitch
value and the pitch value of the current frame. In Figure 6–8, the alteration
of pitch at rank k (Pkalt) is the sum of the old pitch value (Pk) and the
corrector (Ck), whose value is the difference between two linear
interpolations.
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Figure 6–8. Alter Pitch Curve Slope: Value Percentage
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Click on Modify Pitch in the Pitch submenu of the Modify Menu, and the Alter
Curve Slope window appears:

Figure 6–9. Alter Curve Slope Window

Select a zone for curve slope alteration. The orientation of the cluster
(left-to-right or right-to-left) is indicated by an arrow in the lower left part of the
window (see Figure 6–9). To change the orientation from left to right, click the
cursor at the right edge of the selection zone, which represents the new curve
slope.

Select a new value for the curve slope using the horizontal cursor on the
display, either by clicking the mouse or using ↑  and ↓ . To transfer
measurement, click on Update or OK, or click on Transfer Measurement in the
Measurement Menu at the top of the Alter Curve Slope window.
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� Set Unvoiced Cluster CONTROL  + Q : Unvoices voiced frames in a
selection.

� Set Voiced Cluster CONTROL  + J : Voices unvoiced frames in a selection.
A computed pitch value is given to each frame. These values can be
overridden by using Measure Pitch and Calculate Pitch in the Pitch sub-
menu of the Modify Menu to compute pitch values.

Note:

If no pitch value was assigned to a set of frames during LPC analysis, the
frames cannot be voiced and remains unvoiced. However, the Alter Frame
Pitch Value command (see previous text) can be used to introduce pitch to
a previously unvoiced frame.

6.4.2 Energy Commands

� Alter Energy Curve Slope CONTROL  + M : Changes the Energy values of
a cluster of frames to alter the loudness of a word. This command works
like Alter Pitch Curve Slope. (See Figure 6–9 and Alter Pitch Curve Slope
text for details.)

� Set Energy to Zero: Resets the Energy level of frames in a selected cluster.
You are prompted to enter an Energy Threshold. Frames with energy
levels lower than threshold are reset to zero. The corresponding reflection
parameter (A0) for the Frames is also reset. A0 is a logarithmic
representation of the normalized excitation energy (G): A0 = 16 × log2(G).

6.4.3 Modify Edit Parameters Commands

� Alter Word Parameter by CONTROL  + L : Alters the value of a specified
parameter within a selection by a certain percentage value. A positive
value increases the parameter (e. g., Energy, Pitch) value, while a
negative value decreases it. Alteration values range from –99% to +99%.

� Change Parameter Value SHIFT  + CONTROL  + F3 : Changes the value of
a single parameter for the frames in a selection. A Choose Parameter box
prompts you to click once on the parameter to be replaced. Values are in
units appropriate for the parameter chosen (e.g., for Pitch, units are Hz).

Note:

If you choose an undisplayed parameter, there is no visual cue.
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Figure 6–10. Choose Parameter Box

6.4.4 Numerical Modifications CONTROL  + H

Displays a Numerical Modifications window of a two-dimensional table of a set
of frames centered around the current frame. Each column represents a frame
with the parameters of Energy (A0), Pitch (F0), and the reflection parameters
(Ki):
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Figure 6–11.Numerical Modifications Window

The value of every parameter in each frame can be altered. Clicking on the
value to be changed highlights it. Type in the new value. Clicking on Synch.
Cursor Center (below the table in the Numerical Modifications window) syn-
chronizes a selected value with the current cursor in the Signal or Parameter
window, so that moving the cursor in the Signal window automatically re-cen-
ters the frames in the Numerical Modifications window.

As with the SDS5000, you can select a zone before Numerical Modifications
in order to center a set of frames. If no selection is made, 21 frames are
centered around the current cursor position.

To play the signal while the Numerical Modifications window is displayed, use
the following play keyboard commands:

Original Synthetic Coded Compressed

Play All F5 Shift + F5 Ctrl + F5 Shift + Ctrl + F5

Stop Play F6 Shift + F6 Ctrl + F6 Shift + Ctrl +F6

Play Word F7 Shift + F7 Ctrl + F7 Shift +Ctrl +F7

Play Selection F8 Shift + F8 Ctrl + F8 Shift + Ctrl + F8

Play Left F11 Shift + F11 Ctrl + F11 Shift + Ctrl +F11

Play Right F12 Shift + F12 Ctrl + F12 Shift + Ctrl + F12
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You can also use the Play commands at the top of the Numerical Modifications
table: All, Word, Left, Right, Selection, Frame, and Stop.

Use the four Modify menu commands at the top of the Numerical Modifications
table to edit frames within the table:

� Set Unvoiced Cluster CONTROL  + Q

� Set Voiced Cluster CONTROL  + J

� Set Energy to Zero CONTROL  + �

� Restore Energy Levels CONTROL  + M

6.4.5 Compression Thresholds Commands:

The View Word Status box in the View Status submenu of the View Menu
displays a window containing information regarding the status of a specific
word as shown in Figure 6–12. This information is useful in the compression
process.

Figure 6–12. Word Status Window

Compression Thresholds commands allow you to adjust the threshold level for
compressed speech. An average low-level threshold is automatically defined
for the application. WINSDS compares adjacent frames to determine how
similar they are in pitch, energy, and K-parameters. This is done by computing
a Cepstrum (a Fourier transform of the power spectrum) for each frame and
finding the distance (difference) between the two Cepstra. If the distance is
small, then the frames are similar. Any set of frames whose Cepstral distance
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is lower than the defined threshold is replaced by one average frame and the
appropriate bit repeat factor. Any change in the compression rate is shown in
the Word Status display. The changes are saved in the Word Access table or
in the binary code file.

To Select a Word for compression rate change, double-click on the word, or
position the cursor on the word (with no other words selected). To select a
zone, drag the cursor across the zone pressing the left mouse button. Select-
ing the parameter [Fr.Thrshld] of View Other Parameters in the View Menu dis-
plays Compression Thresholds as well as other edit parameters.

� Application Repeat Threshold: Application threshold change resets any
other current threshold settings.

� Word Repeat Threshold: Alters the bit repeat threshold for the current
word. A prompt appears for a compression threshold to be applied to the
entire selection of frames of a word. The default compression rate is the
application bit repeat threshold set in the application folder description file.

� Selection Repeat Threshold CONTROL  + S : Alters the bit repeat threshold
on a selection of frames extending across words. A prompt appears for the
compression threshold for the entire selection. As previously shown, the
default compression rate is the application bit repeat threshold set in the
application folder description file. To listen to the modified compressed
speech, click on Play Synthetic Word with Compression in the Play Menu
or on the Play Pad, or use the Play Compressed Speech keyboard
commands (see previous description).

6.4.6 Formant Editing Command:

Formant Editing is an optional editing feature. Formants are resonances in the
spectrum of a sound that are shaped by the vocal tract. Poles are resonances
in the LPC filter that are derived from the K-parameters; they are
approximations of formants. There is not always a one-to-one
correspondence between formant resonances and pole resonances.

The Formant Editing command extracts formant or pole frequencies and
bandwidths for the current frame, and displays them in the Formant Editing
window as shown in Figure 6–13:
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Figure 6–13. Formant Editing Window

The Poles column refers to the frequency of the pole resonances. The Delta
f column refers to the bandwidth of that resonance.

You may change the displayed formant values. Then, click on OK to convert
new values to LPC information.
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7.1 Creating a New List

A List or List File is another name for a Concatenation File, which consists of
a list of concatenations or Words. Lists have many uses. For instance, a re-
cording script can be typed directly into the WINSDS application as a List or
Lists, a given Word can be tested in various contexts (i. e., concatenations or
Lists), and sequences of numbers, letters, or words can be monitored for Pitch
and Energy consistency.

To create a New List, go to the FILE Menu and click on New List File, or use

the Edit Lists   icon on the Toolbar, or click on Edit Lists option in the View
Database Word Table. An Edit List File window appears on the screen. Lists
may be created and edited as described in the following sections.

Figure 7–1. Edit List File Window
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Each List begins on a new line and has the following syntax:

LIST 1 /word1:1/word2:1/word3:1. . .

LIST 2 /word1:1/word4:1. . .

where each Word is followed by a colon and Word Version number. (Colon and
Word Version number are optional for Words with only one version.)

Note:

If a new List is created before recording the Words in the List, then Version
1 of the Word, which appears in the Word Status Table, represents only the
Word label from the List. Version 2 of the Word is created when the signal
is recorded.

7.2 Open an Existing List File

If you usually begin your work sessions by Editing a List, go to the SETUP
Menu, Options submenu, and click on Startup, and then on Invite to Edit List
at Startup. A check mark appears in front of this command, and the next time
WINSDS is started, a message appears asking you if you want to edit a List.
If you do not want this message to appear, click on the checked command and
the check mark disappears. The message will not appear the next time
WINSDS is started.

Many Lists may be created in a given Application. The Lists remain with the
Application and cannot be transferred to other Applications. To open a pre-
viously created List, go to the FILE Menu and click on Open a List File. A box
displays all List Files ([filename.lst]) created in the given Application. Click on
the desired List File in the Open List File box, and then click on OK, or simply
double-click on the selected file.
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Figure 7–2. Open List File Box

Note:

If a List File is currently open, either in the background or as an icon, you must
first close the current file using the Close List File command in the FILE Menu
before opening another List File.

7.3 List Commands

7.3.1 Read a Word Window

One command used in creating Lists is in the Read a Word window:

EDIT LISTS: Clicking on the Edit Lists. . . command in the Read a Word
window causes the window title to change to Get a Word for List. Double-
clicking on each word in the order they are to appear in the List copies the
words to the current List in the Edit List File window.

7.3.2 Edit List Command Buttons

There are Edit List command buttons under the Edit List work area:

F9: NEW LIST: At the beginning of a new line, prints the word, LIST,
followed by an appropriate (consecutive) List number. Used when creating
a new List or concatenation (e. g., sentence, string).

GO TO LIST: Positions the cursor on a previously created List.
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F8: EDIT VERSION: Different versions of a Word with the same Label may
appear in one or more Lists to represent slight intonation differences, alter-
nate takes, parameter modifications, etc. The F8: Edit Version command
allows the user to change a Version Marker at the end of the current Word
after a colon (:). The default version is 1.

F7: DUPLICATE LIST: To determine how different versions of a Word
sound in the same context, a given List can be copied using the F7:
Duplicate List command, then the version of the Word can be changed
using F8: Edit Version.

F2: UPDATE: Saves the List file. You are asked to type in a name for a new
List in a Save Current List File As window

CLOSE: Closes the Edit List File window.

7.3.3 Playing Lists Using the Buttons in the Edit List File Window

Lists can be played on either Channel 1 or Channel 2 using the buttons in the
Edit List File window under those headings.

CHANNEL 1

F3: READ: Displays the List in the Signal Display window on Channel 1.
Choose Synthetic (Uncoded), Coded, or Compressed to hear.

F5: PLAY: Plays the Synthetic, Coded, or Compressed version of the List
selected.

CHANNEL 2

F4: READ: Displays the List in the Signal Display window on Channel 2.
Choose Synthetic (Uncoded), Coded, or Compressed to hear.

F6: PLAY: Plays the Synthetic, Coded, or Compressed version of the List
selected.

The Edit List File window may be recalled at any time by clicking on Edit Lists

in the EDIT Menu or on the Edit Lists icon on the Toolbar .

7.4 Viewing a List

7.4.1 VIEW CHANNEL LIST 1

This command displays a window with a formatted Object List for Channel 1,
which results from a List display or from Recording Word-by-Word. You may
select the formatted Words and copy them to the Windows Clipboard using the
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[Ctrl+Insert] keys. Create a new List in the Edit Lists window and paste the
Words using the [Shift+Insert] keys.

Figure 7–3. View Object List Window

7.4.2 VIEW CHANNEL LIST 2

This command works the same as the VIEW CHANNEL LIST 1 command.

7.4.3 VIEW OBJECT LIST

This command displays an Object List. A box prompts you to type in the num-
ber of the Object List that you want to view.

7.5 Read a List

Click on Read a List under Edit Signal 1 or Edit Signal 2 in the EDIT Menu to
read a compiled Object List as a signal. Or, click on one of the left-most Signal
icons on the Toolbar: Read a List

 or Read a Word .

The Scale bar is used to position Word boundaries in a List (concatenation)
as well as the Frame boundaries in each Word. A Word boundary is indicated
by a long vertical green line, while a Frame boundary is indicated by a short
vertical white line on the Scale bar. The distance between two Frame lines rep-
resents the Frame duration.

Figure 7–4. Word Boundaries on Scale Bar
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Note:

If more than 200 frames are displayed on the screen, then only word
boundaries appear.

7.6 Finishing Lists

7.6.1 Close List File

This command closes the current List File.

Note:

When a List File is closed, the current Object Lists in the database is no
longer be accessible. A List may not be read as a signal (Read a List) until
a new List File is opened.

7.6.2 Saving A List

To Save your List, use one of the following commands:

Save List File saves the current List File in the current Application.

Save List File As: Used either when a new List File is created or to archive
a List File by duplicating it. The Save Current List File As window is dis-
played:
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Figure 7–5. Save Current List File as Window

The upper part of the Save Current List File window displays the current List
Files in the Application. In the lower part, enter a file name (maximum of 8
characters with no extension) for the List to be saved. Then click on OK.
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8.1 Saving Your Work

8.1.1 Save Your Work in an Application Folder

Save Application: If you are editing a previously saved application, click on this
command to save your editing changes to that application. The following
messages appear: Saving WINSDS Context and Saving Word Access File. If
you try to save an application that was not saved previously, the Save
Application as. . . window appears (see Figure 8–1).

Save Application As: If you want to save a new application or a previously
saved application that you have edited, click on Save Application as in the File
Menu. The Save WINSDS Application As. . . window appears.

Figure 8–1. Save Application as. . . Window

In the center of the window, a small box lists the drive you are using. To save
an application to a different drive, select the appropriate drive in the drop down
menu. The left window displays the relevant path information. The right
window displays the contents of the applications in the left window. (When a
new application is being created, the right window is blank.)
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There are also two text boxes. In the top text box, you can type the name of
the new subdirectory if you wish to create one for your application. Then click
on the Create subdirectory button below the text box, and the subdirectory
name appears in the left window.

Use the bottom text box to create a new WINSDS application in the selected
root directory. Select the root directory in the left window by double-clicking on
the desired subdirectory. Then type in the application name in the lower right
text box. Remember to limit the application name to a maximum of 8
characters with no extension. Next, click the Create Application button under
the text box, or use the ALT + A  keys. Save the new application by clicking on
OK or use the ENTER  ( ) or ALT + O  keys.

Close Application: Clicking on this command in the File Menu saves your work
and quit WINSDS. At the next start-up, however, no message appears asking
if you want to edit the same application.

8.1.2 Saving Your Current List(s)

Save List File: Saves the current list file in the current application.

Save List File As: Used either when a new list file is created or to archive a list
file by duplicating it. The Save Current List File as window is displayed:

Figure 8–2. Save Current List File as: Window
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The upper part of the Save Current List File window displays the current list
files in the application. In the lower text box, enter a file name (maximum of 8
lowercase characters with no extension) for the list to be saved. Then click on
OK.

Close List File: This command closes the current list file. Note that the current
object lists in the database is longer be accessible. A list may not be read as
a signal until a new list file is opened.

8.2 Printing Your Work

8.2.1 Printer Configuration

Printer Configuration: Clicking on Print in the File Menu and then Printer
Configuration causes a Print window to appear:

Figure 8–3. Print Window

The buttons in the Print window are OK, Cancel, and Setup. Clicking on the
Setup button in the Print window causes a Print Setup window to appear. You
can select the printer and configure printer settings, e. g., vertical (portrait) or
horizontal (landscape) orientation, paper size, and paper feed for the printer.
To print a form (screen) select the horizontal orientation.



Printing Your Work

8-5Saving and Printing Your Work

Figure 8–4. Printer Configuration Window

Clicking on Options opens an Options window:

Figure 8–5. Options Window
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Clicking on the Advanced button opens an Advanced Options window:

Figure 8–6. Advanced Options Window

8.2.2 Print Form Or List(s)

Go to the Print submenu and select the type of item(s) you wish to print:

Print Form CONTROL  + P : When printing a single form (or screen), first choose
the Landscape Setup in the window that appears for Printer Configuration.
Then click on Print Form in the Print submenu of the File Menu. The form is
printed automatically.

Note:

Print Form prints the modal window currently displayed.

Print List: When you click on Print List, a message appears asking you for the
number of the list you wish to print. Before a List File containing the desired
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list can be printed, it must be compiled. In other words, only used lists (or
Object Lists in the database) can be printed. (See Chapter 7, Lists, for more
information on compiling a list.)

Print All Lists: This command automatically prints all Object Lists in the
database associated with the current compiled List File.

8.2.3 Print Numerical Modifications ( CONTROL  + P )

To print the coded data displayed in the Numerical Modifications window, click
on the Print button. Values for all frames of the word are printed as text. For
European A4 paper, frames of coded data are printed by groups of 26 frames
(portrait mode) or 39 frames (landscape mode). For US letter paper, the
number of frames per group is 24 and the number of groups per page is 6.

Note:

 For US letter paper, the last 4 lines of the sixth group of data on page 1 run
over to the second page, and the seventh data group begins on page 3.

8.3 Quit [Exit WINSDS]

To exit a WINSDS Application, go to the File Menu and click on Quit [Exit
WINSDS]. You are asked to confirm the command and save your work. (At the
next start-up, you are asked if you want to reopen the previous application.)
Double-clicking on the left corner button of the main WINSDS window is
equivalent to clicking on Exit WINSDS.

8.4 Deleting Unwanted Files

In order to delete unwanted applications or list files, press ALT  + TAB  to go
to Windows\File Manager. Highlight the files that you wish to delete and click
on Delete in the File Menu or press the DEL . Confirm the deletion by clicking
on OK.
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9.1 Purpose of ROMSDS

The ROMSDS program generates ROMs or EPROMs containing coded
speech obtained from the WINSDS speech development station. In WINSDS,
speech is cut into words, which are stored in application folders. ROMSDS
software allows you to select the desired words from the application folders
and store them in ROM in the desired order. ROMSDS also allows you to
choose a synthesis program, which may be added to ROM storage.

9.2 How ROMSDS Works

ROMSDS software runs on a PC and provides a way to generate vocabulary
data for synthesizer chips.

9.2.1 Making a .RSD Setup File

The Make (.RSD) Setup File command produces a .VOC file in standard text
that can be edited from the current application vocabulary and the current
object lists. The .VOC file, which is used in ROMSDS, contains all the words
and valid lists for the current application, as well as Silence Zones associated
with List Words.

When the vocabulary in your application is saved in final form, go to the File
Menu and click on Make (.RSD) Setup File. A message verifies that a file has
been created. Next, the .VOC file is input to ROMSDS (see subsection 9.2.3).

9.2.2 (.RSD) Setup File

A setup (.RSD) file, which is created automatically, includes setup and
generation parameters. The .VOC file is then merged into the setup file with
a .RSD extension.

9.2.3 ROMSDS

Clicking on ROMSDS in the File Menu inputs the .RSD file to ROMSDS. A
ROM output file is created automatically, which includes the synthesis
program, decoding table, and vocabulary. Silent Words are automatically gen-
erated. The ROM output file can be generated either in binary format or
assembly format (for the 50CXX assembler).

9.2.4 Print

The vocabulary and setup parameters are printed in a ROMSDS.TXT file:
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Figure 9–1. ROMSDS.TXT File

ROMSDS for WINSDS Version 1.2 Copyright TEXAS INSTRUMENTS 1995

 rom output file name:      d:\f104\winsds\welcome.app\wel-
come.rom
 rom file format            assembly
 rom data size              8bits
 rom base location          #0000
 rom physical_size          16 K
 rom fill code              #FF

 vocabulary location        #0001
 vocabulary format

 address format             16bits
 first_word_index           #0000

 word table location        #0001
 number of words location   #0001
 number of_words format     8bits

 list data_format           8bits
 list terminate code        #00
 list table location        #0001
 number of list location    #0001
 number of list format      8bits
 list access table location #0001

 energy number of bits      4
 stop code                  #0F
 silent code                #00

 no program

VOCABULARY read from d:\f104\winsds\welcome.app\ with 3 words
   0 ”Welcome:1”                                 
             at #0000 size #00FB ( 251)  file 00000001.BIN
   1 ”Enjoy WINSDS:1”                            
             at #00FB size #036D ( 877)  file 00000002.BIN
   2 ”Dual channel capabilities:1”               
             at #0468 size #074E (1870)  file 00000003.BIN

LIST table build (size 4 elements) with 1 lists

NO SILENT generated

Assembly code file generation in progress
  Writing number of words ...
  Writing number of lists ...
  Writing word access table ...
  Writing list access table ...
  Writing list table ...
  Writing vocabulary ...
  Writing silent words ...

End of assembly code file generation
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ROMSDS for WINSDS Version 1.1 Copyright Texas Instruments 1995 rom
output file name:

c:\winsds\romsds.app\romsds.ROM

9.3 ROM Data Organization

The following features are stored in ROM:

Word Data is in a bit-stream format, which represents the coded and
compressed vocabulary. This list is the only feature necessary to
synthesize coded speech. Each word is assigned a unique number.

Word Access Table is in the form of an address chain at the beginning of
the bit-stream representation of a word, with each address pointing to the
word data. This table is optional and indexed by word number.

Concatenation Table (similar to Lists): This table contains the
concatenations used in the ROM-based application. Each word is defined
by a number. Each concatenation is equivalent to a list (or sentence). At
the end of the concatenation is a user-defined List Termination Code. This
table is optional.

Access Table to concatenations is in the form of an address chain, with
each address pointing to the beginning of each concatenation. This table
is optional.

Synthesizer Program (for the chip synthesizer) and associated Decoding
Table: These are optional and may be stored in ROM independently.

Number of Words (optional)

Number of Lists (optional)

Note:

The minimum requirement for ROM generation is the Word Data. That is, the
only data needed directly by the ROMSDS software for ROM generation is
the Setup (.RSD) file. You can edit this text file outside the ROMSDS
application as long as the format complies with the file syntax rules. This file
can be generated automatically by WINSDS for word and concatenation
descriptions using the Make (.RSD) Setup File command in the File Menu.



Data Representation and Coding

9-5ROMSDS

9.4 Data Representation and Coding

9.4.1 Addressing Modes

The ROM may be addressed in several modes using the following parameters:

9.4.1.1  The ROM Data Format

This is the format of the minimum addressable data. It may be 8 or 16 bits. Ad-
dresses in ROM increment by 1 between two successive data elements.

Data may be Reflected: The data may be stored in Normal mode (i.e., bit-
by-bit in memory), or it may be stored in Reflected mode, in which the bit
order of each minimum addressable data element is reversed. The
following items may be reflected:

� Vocabulary Data
� Number of Words Item
� List Data
� Number of Lists Item

Data may be Swapped: In the ROM, values occupying more than one
minimum addressable element are stored in more than one element with
LSB (Less Significant Byte) first, and MSB (More Significant Byte) last. In
the output ROM file, these elements can be swapped (i.e., MSB first, LSB
last).

9.4.1.2 The Addressing Format

The manner in which data is addressed depends on the quantity of data to be
addressed and on the hardware.

� 16-bit Addresses may address up to 64k bytes of memory space
� 24-bit and 32-bit addresses access over 250k memory. The choice

between these two modes depends on the hardware.
� Addresses may be Reflected: Reverses the bit order of each minimum

addressable data element defining the address.
� Addresses may be Swapped: If the addressing format is larger than the

ROM data format, the addressable elements composing the address may
be reversed. For example, if the ROM addressable format is 8 bits and the
address format is 16 bits, in Swap Mode, the high-order byte of the
address is first, and the low-order byte second. If the target address is
$100C, then in unswapped mode, the first byte of the address contains
$0C and the second byte $10.
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Figure 9–2. Addresses may be Swapped

UNSWAPPED SWAPPED

Unreflected
m 7 0 15 8 m = memory position

Unreflected
m + 1 15 8 15 8 m + 1

Reflected
m 0 7 8 15 m

Reflected
m + 1 8 15 0 7 m + 1

Figure 9–3. Address/Data Representations in Swapped and Unswapped Modes

Address Size ROM Data Size = 8 bits ROM Data Size = 16 bits

Unswapped
m 7 0 m 15 0

16 bits

Unswapped
m + 1 15 8

16 bits

Swapped
m + 1 15 8 Ignore

Swapped
m 7 0

m 7 0

Unswapped m + 1 15 8

24 bits
m + 2 23 16 Illegal

24 bits
m + 2 23 16

Swapped m + 1 15 8

m 7 0

m 7 0

Unswapped
m + 1 15 8

Unswapped
m + 2 23 16 m 15 0

32 bits
m + 3 31 24 m +1 31 16

32 bits
m + 3 31 24 m +1 31 16

Swapped
m + 2 23 16 m 15 0

Swapped
m + 1 15 8

m 7 0

9.4.2 SETUP FILE STRUCTURE

The source file for ROM generation is called the Setup file with the default file
extension of .RSD. This file can be generated automatically using the
concatenations (lists) of a WINSDS application. This file is stored in the
application folder.
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Note:

 If this file is generated by the user, independent of WINSDS software, it is
the user’s responsibility to comply with the syntax of this file format. In
addition, it is recommended for organizational purposes to put this file in the
appropriate Application folder.

This .RSD text file consists of three sections:

� Setup Section defines the setup parameters, giving the location of the
various programs or tables in use and the format for addresses and data.

� Word Section defines the words selected from the application.

� List Section (optional) defines optional Lists or concatenations used for
ROM generation.

Note:

Each file line is limited to 250 characters. Comments, preceded by a
semicolon (;), may be inserted anywhere. (Anything on the line following the
semicolon is ignored. ROMSDS knows only a few keywords that are not
key-sensitive.)

9.4.3 Setup Section

The Setup section starts with the keyword: %Setup. Because it is important to
organize the order of data in the synthesizer chip and to provide access for the
data features generated in the ROM, you are given the option to modify param-
eters. That is, you can select or adjust the ROM Setup file. Each parameter
is followed by an abbreviation in brackets, which is used to set each parameter
in the Setup file. Only one parameter per line is permitted.

Note:

If a default value is taken for a given parameter, the parameter should not
appear in the Setup file, or it should appear as a comment (preceded by a
semicolon). Hexadecimal values are accepted in the following formats: $FF,
#FF, >FF.
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The following parameters define the format and addresses of the data fields
defined in the ROM:

ROM Output File [ROM_OUTPUT_FILE]

This is the Binary or Assembly file resulting from ROM generation, which
occurs in the current directory. If this parameter is missing, ROM
generation will not take place. The file is specified as filename.ext.

ROM File Format [ROM_FILE_FORMAT]

Specifies whether the ROM Output File is a Binary file or an Assembly
50CXX file. Keywords for this parameter are Binary and Assembly.

Note:

In binary format, be sure that filename.syn shows the correct path for the
coding table.

ROM Data Size [ROM_DATA_SIZE]

Defines the ROM data format, which is the format of the minimum
addressable data. Accepted values are 8 bits or 16 BITS. Addresses in
ROM increment by 1 between two successive data elements. Default is 8
bits.

ROM Base Location [ROM_BASE_LOCATION]

Start address of ROM. Default is 0. Ignored in Assembly mode.

ROM Physical Size [ROM_PHYSICAL_SIZE]

Defines the total size of the Output Binary File (i.e., the ROM image) in
number of Kbytes or KWords from 1 to 256 with a step size of 1). Any value
is accepted. Ignored in Assembly format/mode. Default is 16 (Kbytes or
KWords depending on ROM data size).

ROM Fill Code [ROM_FILL_CODE]

In Binary mode, it allows you to fill unused portions of ROM. Default value
is $FFFF. Not used in Assembly mode.

Reflected Data Format [REFLECTED_DATA]

Reverses high-order and low-order bits in data. Accepted values are on or
off. Default value is off.
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Swapped Data Format [SWAPPED_DATA]

Swaps bytes in data. Accepted values are on or off. Default value is off.
Ignored in Assembly mode.

Vocabulary Location [VOCABULARY_LOCATION]

Defines the physical address of the vocabulary data in decimal or hexade-
cimal. If the parameter value is –1, the vocabulary will not be generated.
This is ignored in Assembly mode.

Address Size [ADDRESS_SIZE]

Defines the address format (in bits). Accepted values are 16 bits, 24 bits,
or 32 bits. Default value is 16 bits.

Reflected Address Format [REFLECTED_ADDRESS]

Reverses high-order and low-order bits of the addressable data elements
of an address. Accepted values are on or off. Default value is off.

Swap Address Format [SWAPPED_ADDRESS]

Reverses high-order and low-order addressable data elements of an ad-
dress. This can only occur if the size of the address is larger than the ROM
data size. Otherwise, this parameter is ignored, even if it is defined. Ac-
cepted values are on or off. Default value is off. Ignored in Assembly mode.

Word Access Table Location [WORD_TABLE_LOCATION]

If required, defines the Word Access Table location (i.e., physical
address). Decimal or hexadecimal values are accepted. This table is op-
tional. If the parameter value is –1, this table is not generated (i.e., default
value).

Number of Words Location
[NUMBER_OF_WORDS_LOCATION]

If required, defines the physical address where the Number of Words is
indicated. Decimal or hexadecimal values are accepted. This value is op-
tional. If the parameter value is –1, this parameter is not generated (i.e.,
default value). The parameter is declared by an EQU statement in
Assembly format.

Number of Words Size [NUMBER_OF_WORDS_SIZE]

Defines the format to describe the Number of Words. Accepted values are
8 bits or 16 bits. Default value is 8 bits.
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Reflected Number of Words
[REFLECTED_NUMBER_OF_WORDS]

Determines if the Number of Words parameter is Reflected. Accepted
values are on or off. Default value is off.

Swapped Number of Words
[SWAPPED_NUMBER_OF_WORDS]

Determines if the Number of Words parameter is Swapped. Accepted
values are on or off. Default value is off. Ignored in Assembly mode.

First Word Index [FIRST_WORD_INDEX]

Defines the number of the first Word (e. g., 0 or 1). Default value is 0.

List Table Location [LIST_TABLE_LOCATION]

Defines the physical address of the List (Sentence) Table. Decimal or
hexadecimal values are accepted. This table is optional. If the parameter
value is –1, this table is not generated.

List Data Size [LIST_DATA_SIZE]

Defines the size of each List data element in bits. Accepted values are 8
bits and 16 bits. Default is 8 bits.

Reflected List Data [REFLECTED_LIST_DATA]

Determines if the List data is Reflected. Accepted values are on or off.
Default value is off.

Swapped List Data [SWAPPED_LIST_DATA]

Determines if the List data is Swapped. Accepted values are on or off.
Default value is off. Ignored in Assembly mode.

List Termination Code Data [LIST_TERMINATE_CODE]

Defines the numerical value of Concatenation separators. Decimal or
hexadecimal values are accepted. Default value is “0.”

Number of Lists Location [NUMBER_OF_LIST_LOCATION]

If required, defines the physical address where the Number of Sentences
is located. Decimal or hexadecimal values are accepted. This value is op-
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tional. If the parameter value is –1, this table is not generated (i.e., default
value). In Assembly format, defined by EQU statement.

Number of Lists Size [NUMBER_OF_LIST_SIZE]

Defines the format to describe the Number of Lists. Accepted values are 8
bits or 16 bits. Default value is 8 bits.

Reflected Number of Lists [REFLECTED_NUMBER_OF_LIST]

Determines if the Number of Lists parameter is Reflected. Accepted
values are on or off. Default value is off. Ignored in Assembly mode.

Swapped Number of Lists [SWAPPED_NUMBER_OF_LIST]

Determines if the Number of Lists parameter is Swapped. Accepted
values are on or off. Default value is off. Ignored in Assembly mode.

Concatenations Access Table Location

 [LIST_ACCESS_TABLE_LOCATION]

If required, defines the physical address of the Lists (Sentences) Access
Table. Decimal or hexadecimal values are accepted. This value is option-
al. If the parameter value is –1, this table is not generated (i.e., default
value).

Energy Bits [ENERGY_BITS]

Defines the number of bits for energy coding. Default value is 4. This and
the next two parameters are used to generate silence.

Stop Code [STOP_CODE]

Defines the Stop Code for vocabulary (coded as energy). Default value is
$0F.

Silent Code [SILENT_CODE]

Defines the code for a Frame of Silence used by the Automatic Silence
Generator. Default value is 0.

Synthesis Program File [PROGRAM_FILE]

This parameter contains the path and name of the synthesis program to 
be inserted in the ROM. This file also includes the decoding table for the



Data Representation and Coding

 9-12

synthesizer chip. This parameter is optional. Default is empty. This occurs
if the parameter is not present in the Setup file. In Assembly format, the
parameter is defined in a Copy statement.

Note:

You must define the Vocabulary and Lists locations as a function of the total
number of phrases and the mean number of words per phrase.

Figure 9–4. Example of a ROMSDS Setup File
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9.4.4 WORD SECTION

Each time a new word is defined, ROMSDS attaches an internal number to it.
These internal numbers increment steadily by 1 from 1, and they are displayed
in the vocabulary listing. The internal numbers must be used to define sen-
tences. This section is defined by the keyword:

%VOCABULARY

%Vocabulary is followed by a complete path and filename definition for the
chosen Application folder. Numbers start at 1 and are incremented by 1.

Figure 9–5. Word Section

%VOCABULARY “c:\winsds\apps\goat.app\goat.WRD”

goat kid2:1 ; word 1

GOAT 10–19:1 ; word3

9.4.5 LIST SECTION

This section is defined by the keyword: %List, which is followed by a list of
Word internal numbers separated by slashes (“/”). A line may append to the
next one if it is too long to fit on the physical line. The end of a list is marked
with double slashes (“//”).

Figure 9–6. List Section

%LIST

;

goat kid2/GOAT 10–19,20/GOAT 10–19//

9.5 Example of an Assembly File

ROMSDS produces an Assembly file in which data is generated. Each line of
the file ends in a semicolon (;) followed by offset information.

Figure 9–7. Assembly (.ROM) File

*Partial file generated by ROMSDS V1.2
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* Number of words in vocabulary
NWORD EQU     1
* Number of lists
NLIST EQU    1
* Application program
        COPY    test.syn
* Word access table
WORDT   EQU     $               * start of word table
        DATA    VOC+#0000       * word   1 ”(_un_):1”
* Lists access table
LISTT   EQU     $               * start of list access
table
        DATA    LISTE+#0000     * list   1
* Lists content
LISTE   EQU     $               * start of list table
* list 1 ;#0000
        DATA    #0001,#0007,#0003,#00FF
        DATA    #0002,#0008,#0001,#0007,#0003,#00FF
* Vocabulary
VOC     EQU     $               * start of vocabulary
* word   1 ”(_un_):1”
        BYTE    #00,#00,#00,#00,#00,#00,#00,#08  ; #0000
        BYTE    #68,#FD,#12,#4C,#B6,#B7,#B2,#18  ; #0008
        BYTE    #46,#F4,#50,#ED,#B5,#2C,#C6,#69  ; #0010
        BYTE    #2D,#75,#FB,#A0,#87,#72,#59,#2B  ; #0018
        BYTE    #DD,#3E,#99,#2D,#96,#D6,#4A,#77  ; #0020
        BYTE    #AC,#6A,#4B,#84,#D5,#D2,#1F,#BB  ; #0028
        BYTE    #3C,#62,#1A,#A5,#F4,#E7,#29,#8F  ; #0030
        BYTE    #BA,#46,#29,#FD,#B1,#A9,#23,#E1  ; #0038
        BYTE    #56,#4B,#7F,#5E,#EA,#4A,#6A,#D5  ; #0040
        BYTE    #32,#9C,#A7,#3C,#92,#52,#B6,#0C  ; #0048
        BYTE    #E7,#AD,#8E,#86,#54,#2D,#FD,#F9  ; #0050
        BYTE    #C8,#A3,#29,#55,#4A,#7F,#DE,#F2  ; #0058
        BYTE    #5A,#4A,#A4,#D2,#9D,#8F,#3C,#16  ; #0060
        BYTE    #12,#AB,#F4,#E7,#23,#AE,#B8,#44  ; #0068
        BYTE    #2E,#ED,#79,#89,#23,#2E,#91,#4B  ; #0070
        BYTE    #7D,#9E,#F2,#88,#99,#A3,#52,#1E  ; #0078
        BYTE    #87,#3C,#6E,#66,#25,#14,#FB,#C4  ; #0080
        BYTE    #0E,#8B,#59,#4D,#D9,#56,#D9,#E3  ; #0088
        BYTE    #62,#E6,#52,#B6,#35,#66,#06,#6B  ; #0090
        BYTE    #F8,#94,#6C,#71,#E8,#C9,#12,#CE  ; #0098
        BYTE    #C5,#B3,#36,#AA,#31,#97,#53,#E1  ; #00A0
        BYTE    #21,#DA,#68,#88,#D5,#58,#30,#2B  ; #00A8
        BYTE    #5E,#0B,#8A,#75,#14,#9D,#A2,#13  ; #00B0
        BYTE    #42,#18,#1D,#00,#00,#00,#00,#00  ; #00B8
        BYTE    #00,#00,#00,#E0,#01
        BYTE    #00,#00,#C0,#03
. . .
* silent duration 3
        BYTE    #00,#80,#0F
* silent duration 3
        BYTE    #00,#00,#00,#C0,#07
        END
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9.6 ROMSDS Program Start-Up

The ROMSDS software generates the contents of chip memory using
information in the Setup File. The ROMSDS program is called up at the DOS
level. The current setup parameters and vocabulary are taken from the Setup
File and the current application. Options such as Listing Output and No PROM
Generation are also found in the Setup File. A different Setup File may be
called up using the line command input: >ROMSDS setupfile.RSD (Return).
For example:

>C:\WINSDS\ROMSDS\ROMSDS C:\WINSDS\APPS\GOAT.APP\GOAT.RSD

This command automatically generates the ROM Output File. The ROMSDS
software generates the ROM file used to burn the ROM and may contain the
synthesis program for the chip, the decoding table, the speech data, and the
addressing scheme. The address of each concatenation (list) may be found
in ROM, while the address of each word may be found in the optional Word
Access Table.

During processing, ROMSDS reports execution progress on-screen. If an
error occurs, ROMSDS displays relevant information and stops. Reports can
be redirected to an output file with the redirection ([>]) key. For example:

>C:\WINSDS\ROMSDS\ROMSDS  
C:\WINSDS\APPS\GOAT.APP\GOAT.RSD

C:\WINSDS\APPS\GOAT.APP\GOAT.LST

Note:

The extension .RSD is not necessary; it is the default extension for the
ROMSDS Set file.
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10.1 Introduction

Sound Editor is a Windows application that allows you to create and edit sound
waves for the WINSDS. You can:

� Edit and process speech signals from a WINSDS Application

� Generate sound samples and wave samples in WINDOWS Multimedia
WAVE format or in SampleVision SMP format

Sound Editor is a multiwindow program that lets you work with different
windows containing sound waves and LPC parameters from different
WINSDS Applications.

Table 10–1. Edit Features

Feature Definition

Copy Copies a selection of sound samples from an active Signal window to the Clipboard for later
use.

Cut Removes a selection of sound-samples from an active Signal window by copying them onto
the Clipboard. From the Clipboard, the selection can be pasted onto other waveforms.

Paste Inserts the sound samples from the Clipboard at the current cursor position or replaces any
selected waveform in an active window.

Horizontal Mirror Inverts the time axis of a selection of sound samples in an active window.

Vertical Mirror Inverts the signal polarity of a selection of sound samples in an active Signal window.

Adjust Envelope Changes the envelope of a selection of sound samples in an active Signal window
according to user-defined values. The pattern is multiplied by the sound-sample selection.

Amplify Increases the amplitudes of a selection of sound samples in an active Signal window.

Mix Adds, subtracts, or multiplies sound samples from the Clipboard to a selection of
sound samples in an active Signal window.

Zoom In Expands the view of a Selection of sound samples in an active Signal window to the full
width of the window.

Zoom Out Redisplays the sound samples from the active Signal window before the last Zoom In
action.
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Using the signal generator functions of Sound Editor, you can generate the fol-
lowing types of signals.

Table 10–2. Signal Generator Functions of Sound Editor

Feature Definition

Sine waves Amplitude, frequency, and duration can be
adjusted.

Saw waves Amplitude, frequency, and duration can be
adjusted.

Square waves Amplitude, frequency, and duration can be
adjusted.

Gaussian distributed white noise Power and duration can be adjusted.

Uniformly distributed white noise Power and duration can be adjusted.

Arbitrary waves drawn by the user Amplitude, frequency, and duration can be
adjusted, with phase continuity.

Sound Editor also provides digital signal processing (DSP) functions.

Table 10–3. Sound Editor DSP Functions

Feature Definition

Spectrogram display Represents the sound wave of a Signal window in the
time-frequency domain by computing and displaying its
spectrogram.

LPC analysis Extracts Linear Predictive Coding (LPC) parameters and
Pitch of a sound wave in a Signal window. These
parameters, which are displayed in the form of an LPC
spectrogram, can be modified.

Signal filtering Filters the sound wave of a signal window with a user-
specified filter.

Envelope shaping Extracts and replaces the sound wave envelope in a giv-
en Signal window with that of a sound wave from a differ-
ent window.

Sound Editor allows you to play sound waves and synthetic sounds using LPC
synthesis.



Features of Sound Editor

 10-4

10.2 Features of Sound Editor

Sound Editor is a multiwindow application program that enables the user to
manipulate data displayed in each window. There are three types of windows:

� Signal windows
� Spectrogram windows
� LPC windows

10.2.1 Signal Window

A Signal window displays the sound waveform (i.e., the temporal
representation of a sound). Each displayed sound waveform is given a title,
shown on the Title bar of the Signal window. The title is in the form:

Signal x: filename

where x is a number representing the Context Identifier (see section 10.2.4).
The filename is the name of the file associated with the displayed sound
waveform (with a default extension name .SIG) if it exists, or Untitled, if there
is no file associated with it. If sound samples in the Signal window are modified,
an asterisk (*) is appended to the filename, indicating that modification
occurred.

In the upper right corner of the Signal window, information about the sound
waveform is displayed, e. g., the label, version number in the WINSDS
Application database, and sampling rate. For example, information for a sound
waveform opened from a WINSDS Application, which is the second version
of the Word labeled as ONE, sampled at 10 kHz, would be:

Label: ‘ONE’ Ver: 2 Fs: 10kHz

In the upper left corner of the Signal window, data for the current cursor
position is given:

C: ( x, y)

where C stands for the current cursor, x for the time instant of the current cursor
position, and y for amplitude of the displayed sound waveform at the current
cursor position.

In the sound display area of the Signal window, red dashed lines give the time
along the horizontal axis and amplitude along the vertical axis. The green lines
at the top and bottom of the display area indicate Frame boundaries of the
displayed sound waveform. If the duration of the displayed sound waveform
is too long, Frame markers are not displayed. The Frames of a displayed
sound waveform are used for LPC analysis. The displayed sound waveform
in a Signal window can be edited and saved to a disk file.
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Figure 10–1. Signal Window

10.2.2 Spectrogram Window

A Spectrogram window displays a sound spectrogram (i.e., a time-frequency
representation of a sound). Each sound spectrogram is displayed along with
a title in the Title bar, which has the form:

Spectrogram x: filename

where x is a numeric Context identifier (see the following). Filename repre-
sents the filename associated with the sound waveform displayed in the Signal
window from which the spectrogram was derived.

A Spectrogram window is divided into two subwindows, a Spectrogram
subwindow above and a Cross-Sectional View subwindow below. In the upper
right-hand corner of the Spectrogram subwindow, is the analysis bandwidth
for the displayed sound spectrogram. The analysis bandwidth is adjustable.
In the upper left-hand corner of the Spectrogram subwindow is data on the
sound spectrogram at the current cursor position, which takes the form:

C: ( x)

where C stands for the current cursor, and x represents the time instant of the
current cursor position. In the spectrogram display area of the Spectrogram
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subwindow, red dashed lines give the time along the horizontal axis and
amplitude along the vertical axis.

The Cross-sectional View subwindow displays frequency information for the
Spectrogram subwindow at the current cursor position. The display is
refreshed each time the cursor position in the Spectrogram subwindow
changes. In the upper left-hand corner of the Sectional View subwindow is
data for the current cursor position in that window, which takes the form:

C: ( x, y)

where C stands for the current cursor, x for the frequency value at the current
cursor position, and y for the spectral power value at the current cursor
position. In the display area of the Sectional View subwindow, red dashed lines
give the frequency along the horizontal axis and power spectrum magnitude
along the vertical axis.

Note:

The sound spectrogram displayed in a Spectrogram window cannot be
edited or saved to a disk file.

Figure 10–2. Spectrogram Window
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10.2.3 LPC Window

An LPC window displays all LPC parameters (except Pitch) extracted from an
LPC spectrogram of a sound waveform. Each LPC spectrogram is given a title,
which is shown in the Title bar of the LPC window. The title is in the form:

LPC x: filename

where x is a numeric Context identifier (see the following). Filename repre-
sents the filename associated with the sound waveform displayed in the Signal
window from which the LPC spectrogram was derived (but with a default ex-
tension .PRM). The LPC window is similar to the Spectrogram window. (See
Section 10.2.2. for details on Spectrogram windows.)

Note:

The LPC spectrogram in an LPC window cannot be edited, but it can be
saved to a disk file. LPC parameters (and Pitch) are saved, but not the LPC
spectrogram.)

Figure 10–3. LPC Window
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10.2.4 Context

Context includes a Signal window, Spectrogram window, and an LPC window
for a signal. It is possible to work with multiple Contexts. A Context is identified
by a unique number displayed on the Title bars of the Signal, Spectrogram,
and LPC windows within the same Context. Each time you open a sound
sample file, import a sound file, or generate a sound, a new Context is created
automatically. When a file is saved, both the sound samples in the Signal
window and the LPC parameters in the LPC window are saved.

Cursors in the three windows of a Context can be locked, so that when the
cursor in one window is moved, the cursors in the other windows move
simultaneously. For example, when the cursor in a Signal window is moved,
the cursors in the Spectrogram subwindow of the Spectrogram window, and
the LPC spectrogram subwindow of the LPC window also move. Likewise,
when the cursor in the Sectional View subwindow of the Spectrogram window
is moved, the cursor in the Sectional View subwindow of the LPC window
moves simultaneously.

10.2.5 Working With The Mouse

You can manipulate data displayed in a window by using the mouse to move
the cursor and select or unselect a set of data.

� To move the cursor to a new position — Click the mouse at the new posi-
tion, or click on the cursor and drag it to the position.

� To Make a Selection — Press the left button on the mouse at the starting
position of the data set and drag it to the end position. This action highlights
the Selection.

� To Select all the displayed data — Double-click the mouse anywhere in the
window.

� To Unselect a set of data — Click the mouse anywhere in the window.

10.2.6 Working With The Keyboard

You can also manipulate data displayed in a window by using keystrokes to
move the cursor and zoom in and out on the horizontal or vertical axis.

� To Move the cursor to a new position — Use →  or ←  to move the cursor
sample-by-sample to the right or left. Holding the arrow keys down moves
the cursor more rapidly. The combinations CONTROL  + →  and CONTROL  +

←  move the cursor 20 samples at a time to the right or left.
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The HOME  and END  keys position the cursor at the first and last sound
samples displayed. The combinations CONTROL  + HOME  and CONTROL  +
END  position the cursor at the first and last samples of the sound wave-

form.

� Increasing the Zoom — Press �  to increase the Zoom on the horizontal
axis (i.e., to reduce the number of samples displayed on either side of the
cursor by a factor of two).

Press *  to increase the Zoom on the vertical axis (i.e., to decrease the
dynamic display by a factor of two).

Note:

These commands do not work if the number of samples displayed is less
than 1/16 of the total number of samples in the sound waveform.

� Decreasing the Zoom: Press �  to decrease the Zoom on the horizontal
axis (i.e., to double the number of samples displayed on either side of the
cursor).

Note:

This command will not work if the total number of samples in the sound
waveform is already displayed.

� Press �  to decrease the Zoom on the vertical axis (i.e., to double the
dynamic display).

� To Move the displayed Vertical Zoom: Press ↑  or ↓  to move the
displayed vertical Zoom in small steps or PAGE UP  or PAGE DOWN  to move
in large steps.

� To Center the displayed Vertical Zoom: Press INSERT  to center the dis-
played vertical Zoom on the sound-sample value at the current cursor
position. This command is useful after you have pressed �  several times
so that the display has disappeared because it is outside the display area.

� To Remove Zoom: Press DEL  to remove the Zoom on the horizontal axis.
Press SHIFT  + DEL  to remove the Zoom on the vertical axis. Press

CONTROL  + DEL  to remove the Zoom from both the horizontal and vertical
axes.
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10.3 Sound Editor Package and Installation

10.3.1 Sound Editor Package

Sound Editor is part of the WINSDS board and software package. Table 10–4
lists the software package files.

Table 10–4. Software Package Files

Feature Definition

SNDEDIT.EXE Sound Editor Windows Executable Code file

SNDEDIT.HLP Sound Editor on-line Help file

CURVEFIL.VBX Sound Editor Signal Window Management module

SPECGRAM.VBX Sound Editor Spectrogram Window Management module

FADER.VBX Sound Editor Data Dialog Control module

SNDDRIVR.DLL Sound Editor Basic Functions module

WAVECONV.DLL Sound Editor Support module for Wave format sound files

SDSDRIVR.DLL WINSDS Board Driver

BA_TMS.A0 WINSDS Board Driver

CMDIALOG.VBX VB Support module

THREED.VBX VB Support module

VBRUN300.DLL VB Support module

10.3.2 Sound Editor Installation

Sound Editor is installed automatically during WINSDS installation.

10.4 Starting Sound Editor

To get into Sound Editor, go to the WINSDS File Menu and click on Sound
Editor. This command exits WINSDS and transfers control to Sound Editor.
The current Application name is also transmitted to Sound Editor.

You can also launch Sound Editor by clicking on its icon  in WINDOWS
Program Manager.
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10.5 File Menu

The File Menu offers several commands for opening and displaying an existing
WINSDS Application Signal file, closing and saving a window, or converting
an existing sound-sample file from another format into the WINSDS sample
format.

10.5.1 Open CONTROL  + O

The Open command in the File Menu opens an existing WINSDS Application
Signal file. An Open dialog box asks for the name of the WINSDS Application
Signal file to be opened. If the filename entered is not a valid filename, a
message appears. If the filename entered is valid, Sound Editor opens the file
and creates a new Signal window to display the file.

If an LPC parameter file (of the opened WINSDS Application Signal file) exists,
it is displayed in the LPC window of the newly created Context. LPC Analysis
Setup parameters, including sampling rate, LPC analysis method, number of
samples per Frame, as well as the Word label and version number, are loaded
into Sound Editor for work on the newly created Context.

Sound Editor maintains a list at the bottom of the File Menu, of names of the
four most recently opened files. Clicking on one of the filenames in the list
opens the corresponding WINSDS Application Signal file.

10.5.2 Close CONTROL  + W

The Close command in the File Menu closes the current active window, i. e.,
a Signal window, an LPC window, or a Spectrogram window. If the data
displayed in the window have been modified since the last Save, Sound Editor
displays a message asking if the data should be saved before closing the
window.

10.5.3 Save / Save (As) CONTROL  + S / CONTROL  + A

The SAVE command in the File Menu can only be used to save data displayed
in a Signal window or an LPC window. A spectrogram cannot be saved. The
Save command saves the data displayed in the current active window (a
Signal or LPC window) to the WINSDS Application from which the Signal file
was opened or to the file on which the last Save action was performed. If the
Signal window or LPC window of the same Context are both open, then they
are both saved. If the data displayed in the LPC window have not been updated
since the last modifications were made to the Signal window, Sound Editor
asks if an Update should be performed before saving.
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Since the WINSDS Application database maintains several versions of Signal
files with the same Word label, data from Signal and LPC windows are saved
to a new version of the label. Thus, filenames for the data displayed in the
windows are changed to new filenames, and the version number changes to
the last version of the label.

If the data displayed in the window is not associated with a disk file (i.e.,
Untitled), the Save command acts as Save As. The Save As command saves
the data displayed in the current active window (Signal or LPC window) to a
different WINSDS Application. If the Signal and LPC windows of the same
Context are both open, they are both saved. If the data displayed in the LPC
window has not been updated since the last modifications were made to the
Signal window, Sound Editor asks if an Update should be performed before
saving.

Clicking on Save As in the File Menu causes a Save As dialog box to appear.
Type in a valid WINSDS Application filename to which the displayed data are
to be saved. A Valid WINSDS Application means that the existing WINSDS
Application’s sampling rate, LPC analysis method, speech synthesizer chip,
transcoding table, and number of samples per Frame for LPC analysis are all
the same as those of the data displayed in the window to be saved. If a valid
WINSDS Application is found, Sound Editor suggests a filename for saving the
displayed data. Then a prompt to enter a Word label appears.

Since the WINSDS Application database maintains several versions of Signal
files with the same Word label, data from Signal and LPC windows are saved
to a new version of the label. Thus, filenames for the data displayed in the
windows are changed to new filenames, and the version number changes to
the last version of the label.

10.5.4 Save to (New) Application  CONTROL + P

Choosing the Save to (New) Application command in the File Menu causes a
Save to New App window to appear as shown in Figure 10–4. To create a new
application, select the directory location where you want to put your New
Application. Then type the name of the Application. Application settings for a
New Application in Sound Editor are found in the Options Menu: (1) Parameter
settings in the LPC Settings submenu, and (2) Sampling rate in the Sample
Rate submenu.
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Figure 10–4. Save to New Application Window

10.5.5 Import WAVE

The Import WAVE command in the File Menu opens a sound-sample file in
Microsoft WAVE format. The sound wave files, with the Microsoft PCM and
ADPCM format and the sampling rates shown in the following list, are
converted to Sound Editor sound-sample file format with either an 8 kHz or
10 kHz sampling rate, selected from the Options Menu:

� 48 kHz
� 44.1 kHz
� 22.5 kHz
� 11.25 kHz

If the sound-sample file in WAVE format contains stereo sound samples,
prompts appear asking whether you want to import only the left channel, only
the right channel, or a mix of both channels (scaled down by a factor of two).

Note:

Since Import Wave uses a sampling rate conversion filter, which runs on the
WINSDS board, this command will not work if the DSP board is not present.

10.5.6 Import SMP

The Import SMP command opens a sound-sample file in SampleVision’s
SMP format. The sound wave files, with sampling rates ranging from 51.2 kHz
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to 8 kHz or 10 kHz, are converted into Sound Editor sound-sample file format
with either an 8 kHz or 10 kHz sampling rate, which is selected using the
Sample Rate command in the Options Menu (see the following).

Note:

Since Import SMP uses a sampling rate conversion filter, which runs on the
WINSDS board, this command will not work if the DSP board is not present.

The converted sound waveform is displayed in the new Signal window of an
automatically created context with no filename (i.e., Untitled). The LPC
parameters, previously set up using the LPC Settings command in the Options
Menu (see the following), are copied to the new Context. The WINSDS
Application in which the imported sound wave is to be saved should have the
same LPC settings and sampling rate as the sound waveform in the Signal
window.

10.5.7 Convert WINSDS

The Convert WINSDS command opens a WINSDS Application Signal file with
either an 8 kHz or 10 kHz sampling rate. A message appears, asking if you
want to convert the file into the Sound Editor sound-sample file format with a
different sampling rate (changing 8 kHz to 10 kHz or vice versa) regardless of
the sampling rate selected using Sample Rate in the Options Menu (see the
following).

If you click on Yes, the file is converted and displayed in the new Signal window
of an automatically created Context with no filename (i. e., Untitled). The LPC
parameters of the WINSDS Application are copied to the new Context. The
sampling rate of the converted sound-sample file is the new sampling rate. The
WINSDS Application should have the same LPC settings and sampling rate
as the sound waveform in the Signal window. The corresponding LPC
parameter file of the WINSDS Application Signal file is not opened, since the
Pitch parameter is not analyzed with the new sampling rate.

If you click on No, the WINSDS Application Signal file is opened, preserving
its original sampling rate. In this case, Convert WINSDS acts just like the Open
command.

Note:

Since Convert WINSDS uses a sampling rate conversion filter, which runs
on the WINSDS board, this command will not work if the DSP board is not
present.
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10.5.8 Import Raw File

The Import Raw File command imports a pre-recorded raw 16-bit sound file
to Sound Editor. Before importing the raw sound file, select the sampling rate
for the imported file using the Sample Rate submenu in the Options Menu.

10.5.9 Exit

The Exit command ends Sound Editor and returns to WINDOWS. Before
exiting, the sampling rate, LPC settings, Auto Fade settings, and Spectrogram
settings (set via the Options Menu), are saved to a file named SNEDIT.INI in
the WINDOWS directory. The next time Sound Editor is started, these settings
are reloaded.

10.6 Edit Menu

10.6.1 Cut, Copy, Paste, And Undo

The Edit Menu offers several commands for editing or Zooming In or Out when
viewing sound samples displayed in a Signal window. Zoom commands are
also available for LPC and Spectrogram windows, as well as for the Clipboard
window (see the Show Clipboard command in the Window Menu).

Cut CONTROL  + X

The Cut command in the Edit Menu copies a selection of sound samples from
an active Signal window to the Clipboard for use later, and the Selection is
deleted from the Signal window. If automatic Cross Fading (set via the Auto
Fade command in the Options Menu) is required, a number of samples before
and after the selection are also copied to the Clipboard for future Cross Fading.

Note:

The extra samples that were copied will not appear on the Clipboard display.
The two ends of the remaining signal after the selection has been deleted are
cross faded.
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Figure 10–5. Cross Fading

After the Selection of sound samples has been copied to the Clipboard (as in
Figure 10.5a), N samples before and after each Selection boundary are
preserved (as in Figure 10.5b). Then the two sections of 2N samples are Cross
Faded through linear interpolation (as in Figure 10.5c). In this way, the
remaining sound waveform preserves its phase continuity. The N is defined by
the Fade Duration parameter set using the Auto Fade command in the Options
Menu. Follow the same procedures to apply Cross Fading to other Edit
commands.

Copy CONTROL + C

The Copy command in the Edit Menu copies a Selection of sound samples
from an active Signal window to the Clipboard for use later. If automatic Cross
Fading (set via the Auto Fade command in the Options Menu) is required, a
number of samples before and after the Selection are also copied to the
Clipboard for future Cross Fading.
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Note:

The extra samples that were copied will not appear on the Clipboard display.

Paste CONTROL  + V

The Paste command in the Edit Menu copies sound samples to the Clipboard
and inserts them at the current cursor position in an active Signal window if no
sound samples are selected in the window. If there is a Selection of sound
samples in the window, the Paste command replaces the current sound
samples of the current active Signal window. If automatic Cross Fading is
required (set by using the Auto Fade command in the Options Menu), both
ends of the Pasted sound samples are Cross Faded with the ends of the sound
samples in the Signal window. If the sampling rate of the remaining sound
samples in the Clipboard is different from that of the current active Signal
window, a message appears asking if you want to continue.

Undo CONTROL + �

The Undo command in the Edit Menu cancels the last editing action on the
sound samples displayed in a Signal window. Sound Editor preserves a trace
of the last editing action performed for each Signal window, so that it can be
canceled.

10.6.2 Mirror

Horizontal Mirror

The Horizontal Mirror command in the Edit Menu inverts the time axis of
Selected sound samples in the current active Signal window. If automatic
Cross Fading is required (set by using Auto Fade in the Options Menu), both
ends of the inverted sound samples are Cross Faded with the ends of the
remaining sound samples in the Signal window.

Vertical Mirror

The Vertical Mirror command in the Edit Menu inverts the polarities of Selected
sound samples for the current active Signal window. If automatic Cross Fading
is required (set by using Auto Fade in the Options Menu), both ends of the
inverted sound samples are Cross Faded with the ends of the remaining sound
samples in the Signal window.

10.6.3 Adjust Envelope

The Adjust Envelope command in the Edit Menu applies user-defined
adjustments to the envelope for Selected sound samples in the current active
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Signal window. If automatic Cross Fading is required (set by using Auto Fade
in the Options Menu), both ends of the adjusted sound samples are Cross
Faded with the ends of the remaining sound samples in the Signal window.

Clicking on this command opens a dialog box for you to draw an envelope
pattern to be applied to the Selection. The vertical axis of the drawing area
represents the normalized amplitude of the drawn envelope pattern. The
horizontal axis represents the time instants of the Selected sound samples,
which are indicated by the number of samples of the Selection. By default, the
envelope pattern is initialized as a flat pattern with an amplitude value of 1.0,
which means that no new envelope pattern is to be applied. Then, the mouse
can be used to drag the initial pattern curve to the desired pattern. Clicking on
OK in the dialog box applies the drawn pattern to the Selection. Clicking on
Cancel cancels the Adjust Envelope command.

10.6.4 Amplify

The Amplify command in the Edit Menu applies a user-defined gain to the
Selected sound samples of the current active Signal window. If automatic
Cross Fading is required (set by using Auto Fade in the Options Menu), both
ends of the amplified sound samples are Cross Faded with the ends of the
remaining sound samples in the Signal window.

Clicking on this command opens a dialog box for you to enter a gain value in
decibels (dB) for amplification. Sound Editor sets minimum and maximum
values for the gain to be entered. A minimum gain of –90 dB, in practice,
attenuates the Selected sound samples to silence. In order to prevent eventual
arithmetic overflow of the amplified sound samples, the maximum gain value
is determined by Sound Editor as a function of the current maximum amplitude
of the Selected sound samples. Clicking on OK in the dialog box applies the
entered gain to the Selection. Clicking on Cancel cancels the Amplify
command.

10.6.5 Mixing

The Mixing option of the Edit Menu offers three commands:

� Add
� Subtract
� Multiply

Using these commands, sound samples from the Clipboard can be added to,
subtracted from, or multiplied by Selected sound samples in the current active
Signal window. If the duration of the sound samples from the Clipboard and
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the Selected sound samples in the Signal window are not the same, the
duration of the resulting mixed samples takes on the value of the shorter
duration. If automatic Cross Fading is required (set by using Auto Fade in the
Options Menu), both ends of the mixed sound samples are Cross Faded with
the ends of the remaining sound samples in the Signal window. If the sampling
rate of the sound samples from the Clipboard are different from that of the
active Signal window, a message appears asking whether you want to
continue or cancel the Mixing command.

10.6.6 Zoom

Zoom In CONTROL  + I

The Zoom In command in the Edit Menu expands a Selection of sound
samples in the current active Signal window to the full width of the window.
There is a maximum of 20 levels for Zoom In. Each time you click on this
command, Zoom level is increased by one.

Zoom Out CONTROL  + F

The Zoom Out command in the Edit Menu redisplays the sound samples of the
current active Signal window as they were before the last Zoom In. Each time
you click on this command, Zoom level is decreased by one.

10.7 Generator Menu

The Generator menu provides commands for generating the following types
of waveforms, for which amplitude, frequency, and duration can be altered.
(Phase continuity is also possible for user-defined Arbitrary waveforms.)

� Sine Waves
� Saw Waves
� Square Waves
� User-defined Arbitrary Waves

Commands are also provided to generate Gaussian and Uniformly distributed
white noise, for which power and duration can be altered.

10.7.1 Sound Wave Commands

Sine Wave

The Sine Wave command in the Generator menu generates a sine waveform
at the current sampling rate (set using the Sample Rate command in the
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OPTIONS Menu). Sound Editor creates a new Context for the generated
sound waveform, displays it in the Signal window of the new Context, and
labels it as Untitled until a new label is assigned. The sampling rate and LPC
parameters, set previously using the LPC Settings command in the OPTIONS
Menu (see the following), are copied to the new Context. The WINSDS
Application to which the generated sound wave is to be saved must have the
same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to enter frequency, ampli-
tude and duration values. Minimum and maximum values for the parameters
are preset by Sound Editor. Clicking on OK in the dialog box applies the values
entered to the signal generation. Clicking on Cancel cancels the Sine Wave
command.

Figure 10–6. Sine Wave (50 Hz)

Saw Wave

The Saw Wave command in the Generator menu generates a saw waveform
at the current sampling rate (set using the Sample Rate command in the
OPTIONS Menu). Sound Editor creates a new Context for the generated
sound waveform, displays it in the Signal window of the new Context, and
labels it Untitled until a new label is assigned. The sampling rate and LPC
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parameters, set previously using the LPC Settings command in the OPTIONS
Menu (see the following), are copied to the new Context. The WINSDS
Application to which the generated sound wave is to be saved must have the
same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to enter frequency, ampli-
tude and duration values. Minimum and maximum values for the parameters
are pre-set by Sound Editor. Clicking on OK in the dialog box applies the values
entered to the signal generation. Clicking on Cancel cancels the Saw Wave
command.

Figure 10–7. Saw Wave (50 Hz)

Square Wave

The Square Wave command in the Generator menu generates a centered
square waveform at the current sampling rate (set using the Sample Rate
command in the OPTIONS Menu). Sound Editor creates a new Context for the
generated sound waveform, displays it in the Signal window of the new Con-
text, and labels it Untitled until a new label is assigned. The sampling rate and
LPC parameters, set previously using the LPC Settings command in the OP-
TIONS Menu (see the following), are copied to the new Context. The WINSDS
Application to which the generated sound wave is to be saved must have the
same LPC settings and sampling rate as the generated waveform.
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Clicking on this command opens a dialog box for you to enter frequency, ampli-
tude and duration values. Minimum and maximum values for the parameters
are preset by Sound Editor. Clicking on OK in the dialog box applies the values
entered to the signal generation. Clicking on Cancel cancels the Square Wave
command.

Figure 10–8. Square Wave (50 Hz)

Draw [Arbitrary Wave]

The Draw command in the Generator menu generates a user-defined arbitrary
waveform at the current sampling rate (set using the Sample Rate command
in the OPTIONS Menu). Sound Editor creates a new Context for the generated
sound waveform, displays it in the Signal window of the new Context, and
labels it Untitled until a new label is assigned. The sampling rate and LPC
parameters, set previously using the LPC Settings command in the OPTIONS
Menu (see the following), are copied to the new Context. The WINSDS
Application to which the generated sound wave is to be saved must have the
same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to enter frequency,
amplitude and duration values. Minimum and maximum values for the
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parameters are preset by Sound Editor. Then you are prompted to draw one
period of the signal to be generated. The vertical axis of the drawing area
represents the normalized amplitude of the drawn signal period. The
horizontal axis represents the time instants of the drawn signal samples, which
are indicated by the number of samples in the signal period. The number of
samples per signal period is determined by the signal frequency entered. The
higher the signal frequency is, the fewer the number of samples per period. By
default, the signal amplitudes to be generated are initialized to zero, which
generates silence.

Use the mouse to drag the initial signal curve to the desired signal period wave-
form. If the Continuous Phase box in the dialog box is checked, the first and
last samples of the drawn signal period have the same amplitude, ensuring
phase continuity in the generation of all required signal periods. Clicking on OK
in the dialog box applies the entered values to the signal generation. Clicking
on Cancel cancels the Draw command.

Figure 10–9. Draw [Arbitrary Wave] (50 Hz)
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10.7.2 Noise Commands

Gaussian Noise

The Gaussian Noise command in the Generator menu generates a Gaussian
law distributed white noise waveform. Sound Editor creates a new Context for
the generated sound waveform, displays it in the Signal window of the new
Context, and labels it Untitled until a new label is assigned. The sampling rate
and LPC parameters, set previously using the LPC Settings command in the
Options Menu (see the following), are copied to the new Context. The
WINSDS Application to which the generated sound wave is to be saved must
have the same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to enter power and
duration values. Minimum and maximum values for the parameters are pre-set
by Sound Editor. Clicking on OK in the dialog box applies the entered values
to the signal generation. Clicking on Cancel cancels the Gaussian Noise
command.

Figure 10–10. Gaussian Noise (1 Hz)
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Uniform Noise

The Uniform Noise command in the Generator menu generates a uniformly
distributed white noise waveform. Sound Editor creates a new context for the
generated sound waveform, displays it in the Signal window of the new
context, and labels it as Untitled until a new label is assigned. The sampling
rate and LPC parameters, set previously using the LPC Settings command in
the Options Menu (see the following), are copied to the new context. The
WINSDS Application to which the generated sound wave is to be saved must
have the same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to enter power and
duration values. Minimum and maximum values for the parameters are pre-set
by Sound Editor. Clicking on OK in the dialog box applies the entered values
to the signal generation. Clicking on Cancel cancels the Uniform Noise
command.

Figure 10–11. Uniform Noise
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10.8 Processing Menu

The Processing Menu contains several commands for the digital signal
processing of sound samples in the current active Signal window:

� Compute and display the spectrogram
� Extract and display the LPC and Pitch parameters
� Filtering
� Envelope Shaping

10.8.1 Spectrogram

The Spectrogram command in the Processing Menu computes the
spectrogram (time-frequency representation) of the sound samples in the
current active Signal window (see Figure 10–2). The computed spectrogram
is displayed in the Spectrogram window of the context of the current active
Signal window.

If the Spectrogram window is not already displayed, it will appear
automatically. If the Spectrogram window is already displayed, then the
spectrogram is recomputed and redisplayed in the same window (since the
sound samples in the current Signal window have been modified since the last
spectrogram computation). If the sound samples in the current Signal display
window have not been modified since the last spectrogram computation, then
the Spectrogram window simply redisplays the previously computed
spectrogram.

The computed spectrogram is displayed in 16 colors, which represent the
power spectrum intensities of the sound spectra. These colors are listed in the
following according to increasing power spectrum intensities:

� Black (low-power spectrum intensity)
� Red
� Green
� Brown
� Blue
� Magenta
� Cyan
� Gray
� White
� Light Red
� Light Green
� Light Cyan
� Light Blue
� Yellow
� Bright White (high-power spectrum intensity)
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The spectrogram analysis bandwidth can be adjusted from 78 Hz to 800 Hz
by using the Spectrogram Options command in the Options Menu. This
enables you to do either a narrow- (e.g., 45 Hz) or wide-band (e.g., 300 Hz)
spectral analysis. Each time a spectrogram is computed, the settings, which
were set using Spectrogram Options in the Options Menu, are used for
computation and display. Spectrogram Options also allows you to specify low
and high clip levels for the spectrogram display. These clip levels clip out the
lower and higher power spectral intensities of the computed spectra for a
better visual display of the spectrogram.

Note:

If the WINSDS DSP board is present, Sound Editor performs the spectral
analysis on the DSP board. If the DSP board is not present, it performs the
analysis on the PC.

10.8.2 LPC Analysis

The LPC Analysis command in the Processing Menu extracts LPC parameters
(the Linear Predictive Coding model of a sound) and Pitch (for speech signals).
The extracted LPC parameters are displayed in the LPC window of the context
of the current active Signal window in the form of an LPC spectrogram. (Pitch
is not displayed.)

If the LPC window is not already displayed, it appears automatically. If the LPC
window is already displayed, then the LPC parameters are re-computed and
re-displayed in the same window provided that the sound samples in the
current Signal window have been modified since the last computation of LPC
parameters. The LPC window is simply redisplayed if the sound samples in the
current Signal window have not been modified since the last LPC computation.

The LPC spectrogram is displayed in 16 colors as in the Spectrogram window
(see section 10.8.1). Spectrogram options also allows you to specify low and
high clip levels for the spectrogram display. These clip levels clip out the lower
and higher power spectral intensities of the computed LPC spectra in order to
obtain a better visual display of the LPC spectrogram.

Each time an LPC analysis is performed, the LPC analysis settings stored with
the context are displayed. This allows you to modify some of the settings for
the analysis to be performed. (However, settings related to the WINSDS
Application setup, i.e., analysis method, coding table, synthesizer chip, and
samples per Frame, cannot be changed.)
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Figure 10–12.  LPC Settings

The LPC spectrogram bandwidth is not affected by Analysis Bandwidth under
Spectrogram Options in the Options Menu. It is determined by the Voiced LPC
analysis window size parameter (LPCV) of the LPC settings of the Context.

Note:

Since LPC Analysis uses the LPC analysis routines, which run on the
WINSDS board, this command does not  work if the DSP board is not
present.

10.8.3 Filtering

The Filtering command in the Processing Menu filters the sound waveform
displayed in the current active Signal window. Sound Editor creates a new
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Context for the filtered sound waveform, displays it in the Signal window of the
new context, and labels it Untitled until a new label is assigned. The sampling
rate and LPC parameters, set previously using the LPC Settings command in
the Options Menu (see the following), are copied to the new Context. The
WINSDS Application to which the generated sound wave is to be saved must
have the same LPC settings and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to draw the filtering
specifications. The vertical axis of the drawing area represents the normalized
gain of the FFT filter. The horizontal axis represents the frequency scale, which
is shown as frequency values in Hz, and is determined by the sampling rate
of the context of the current active Signal window. By default, the filter
frequency components are initialized to 1.0, which results in a pass-all filter.
Use the mouse to drag the initial filter curve to the desired filter form.

Clicking on OK in the dialog box applies the specified filter to the current active
Signal window. Clicking on Cancel cancels the Filtering command.

Note:

Filtering is performed on the DSP board, if present. If the DSP board is not
present, filtering is performed on the PC.

Figure 10–13. Filtering Window
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10.8.4 Envelope Shaping

The Envelope Shaping command replaces the entire envelope of the sound
waveform displayed in the current active Signal window with a user-defined
envelope. Sound Editor creates a new Context for the envelope-shaped sound
waveform, displays it in the Signal window of the new Context, and labels it
Untitled until a new label is assigned. The sampling rate and LPC parameters,
set previously using the LPC Settings command in the Options Menu (see the
following), are copied to the new Context. The WINSDS application to which
the generated sound wave is to be saved must have the same LPC settings
and sampling rate as the generated waveform.

Clicking on this command opens a dialog box for you to draw a new envelope
pattern. The vertical axis of the drawing area represents the normalized
amplitude of the drawn envelope pattern. The horizontal axis represents the
time instants of the drawn envelope samples, determined by the number of
samples in the current active Signal window.

Figure 10–14. Envelope Shaping Window

The envelope displayed in the drawing area is down-sampled with respect to
the signal envelope of the sound samples displayed is the current active Signal
window. A dialog box appears in which the titles of all Signal windows
displayed by Sound Editor are listed. This allows you to extract the envelope
of each displayed Signal window. When the title of a Signal window is selected
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from the list, its envelope is automatically extracted and displayed in the
drawing area.

By default, the envelope of the current active signal window is extracted and
displayed in the drawing area. Use the mouse to drag the initial envelope
pattern to the desired envelope pattern. The Smooth option performs
smoothing of the currently displayed envelope pattern in the drawing area by
applying a moving average window to the envelope pattern. When you click
on the Smooth option, a dialog box appears, asking you to enter the smoothing
window length N, which defines the number of points of the moving average
window centered on an envelope pattern sample to be smoothed as 2N + 1.

Clicking on OK in the Envelope Smoothing dialog box applies the smoothing
procedure using the user-defined smoothing window length, and then closes
the dialog box. That is, clicking on OK replaces the initial envelope pattern in
the current active Signal window with the user-defined envelope pattern. Click-
ing on Cancel cancels the Smoothing command.

Figure 10–15. Smoothed Envelope

Note:

Envelope shaping is performed on the DSP board, if present. If the DSP
board is not present, envelope shaping is performed on the PC.
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Figure 10–16. User-defined Envelope Pattern

10.9 Playback Menu

The Playback Menu contains the following commands for playing the sound
samples in the current active Signal window:

� Play Entire
� Play Selection
� Play Left
� Play Right

10.9.1 Play Entire F5

The Play Entire command in the Playback Menu plays all sound samples
displayed in the current active Signal window. If the Signal window is Zoomed,
then only the Zoomed sound samples are played.

Note:

Since Play Entire uses the WINSDS board for Playback, this command will
not work if the DSP board is not present.
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10.9.2 Play Selection F6

The Play Selection command in the Playback Menu enables you to play a
Selection of sound samples displayed in the current active Signal window.

Note:

Since Play Selection uses the WINSDS board for Playback, this command
will not work if the DSP board is not present.

10.9.3 Play Left F7

The Play Left command in the Playback Menu plays sound samples displayed
in the current active Signal window starting with the first sample to the left of
the current cursor position.

Note:

Since Play Left uses the WINSDS board for Playback, this command will not
work if the DSP board is not present.

10.9.4 Play Right F8

The Play Right command in the Playback Menu plays sound samples
displayed in the current active Signal window starting with the first sample to
the right of the current cursor position.

Note:

 Since Play Right uses the WINSDS board for Playback, this command will
not work if the DSP board is not present.

10.10 Synthesis Menu

The Synthesis Menu contains the following commands for playing synthetic
sound samples from the current active LPC window:

� Synth Entire
� Synth Selection
� Synth Left
� Synth Right

10.10.1 Synth Entire SHIFT  + F5

The Synth Entire command in the Synthesis Menu plays all Frames displayed
in the current active LPC window. If the user has zoomed in on the LPC
window, only the zoomed frames are played.
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Note:

Since Synth Entire uses the WINSDS board for Playback, this command will
not work if the DSP board is not present.

10.10.2 Synth Selection SHIFT  + F6

The Synth Selection command in the Synthesis Menu plays a selection of LPC
frames displayed in the current active LPC window.

Note:

Since Synth Selection uses the WINSDS board for Playback, this command
will not work if the DSP board is not present.

10.10.3 Synth Left SHIFT  + F7

The Synth Left command in the Synthesis Menu plays the LPC frames
displayed in the current active LPC window, starting with the first frame to the
left of the current cursor position.

Note:

 Since Synth Left uses the WINSDS board for Playback, this command will
not work if the DSP board is not present.

10.10.4 Synth Right SHIFT  + F8

The Synth Right command in the Synthesis Menu plays the LPC frames
displayed in the current active LPC window, starting with the first frame to the
right of the current cursor position.

Note:

Since Synth Right uses the WINSDS board for Playback, this command will
not work if the DSP board is not present.
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10.11 Options Menu

The Options Menu contains several commands for setting up Sound Editor’s
working parameters:

� Sample Rate
� LPC Settings
� Lock Cursors
� Auto Fading
� Spectrogram Options

10.11.1 Sample Rate

The Sample Rate command in the Options Menu sets Sound Editor’s working
sampling rate to 8 kHz or 10 kHz. Choice of sampling rate alters the sound
waveform’s sampling rate as it is imported from WAVE or SMP  format or
generated by Sound Editor.

Note:

This command does not affect the sampling rate of a signal in an open or
converted WINSDS application.

10.11.2 LPC Settings

The LPC Settings command in the Options Menu sets up Sound Editor’s work-
ing LPC settings. The system LPC settings affect only the LPC settings of
sound waveforms subsequently imported from WAVE and SMP  formats and
those subsequently generated by Sound Editor.

Note:

This command does not affect the LPC settings of a signal in an open or
converted WINSDS application.

Clicking on this command opens a dialog box for you to modify LPC settings.
These settings should match those of the WINSDS application from which the
word was taken. (See Section 4.4, Application Setup for details regarding
parameter settings.)
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LPC Parameter Parameter Description

LPC Method LPC analysis method (LPC 10 or LPC 12)

Chip Speech synthesizer chip used for synthesis

Coding Table Transcoding table used for synthesis

NFRAME Number of samples per Frame

LPCV Number of samples in the Voiced LPC analysis window

LPCU Number of samples in the Unvoiced LPC analysis window

T0MIN Minimum Pitch period in milliseconds (ms)

T0MAX Maximum Pitch period in milliseconds (ms)

T0VAR Minimum percentage of variation allowed per Pitch period for
Pitch re-evaluation

HAMV Flag for Voiced analysis Hamming window

HAMU Flag for Unvoiced analysis Hamming window

LPCLEV Threshold in decibels (dB) for zeroing LPC parameters during
LPC analysis

EMPHV Voiced analysis pre-emphasis coefficient

EMPHU Unvoiced analysis pre-emphasis coefficient

KEXIV Weighting factor for Voiced speech synthesis excitation energy

KEXIU Weighting factor for Unvoiced speech synthesis excitation
energy

KSIG0 Weighting factor for Global speech synthesis excitation energy

Clicking on OK in the dialog box validates changes made to the settings. Click-
ing on Cancel cancels changes made to the settings.

Note:

The WINSDS Application in which the generated sound wave is to be saved
should have the same LPC settings and sampling rate as the sound
waveform in the Signal window.

Upon exiting from Sound Editor, the LPC settings are saved to a file named
SNEDIT.INI in the WINDOWS directory. The next time Sound Editor starts up,
these settings are reloaded.
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10.11.3 Lock Cursors (Toggle)

The Lock Cursors command locks the cursors of the Signal window, the LPC
window, and the Spectrogram window within a single Context. When the
locked cursor is moved in one window, cursors in the other windows move
simultaneously. For example, when you move the cursor in the Signal window,
the cursors in the Spectrogram window and the Spectrogram subwindow
moves, as does the cursors in the LPC window and the LPC spectrogram
subwindow.

Cursors in windows of different Contexts can be locked separately. Each time
the command is activated, the cursors are locked in all three windows within
the same Context of the current active window without affecting the cursors in
windows in other Contexts.

“Lock Cursors is a toggle command, so that if the cursors of the current active
window Context are not already locked, they become locked, and the
command display is checked.

10.11.4 Auto Fading

The Auto Fading command in the Options Menu sets automatic Cross Fading
options for the editing commands in the Edit Menu.

Clicking on Auto Fading opens a dialog box with the following options.
Checking the Auto Fading Edit box in the dialog box applies Auto Fading
automatically when using editing commands from the Edit Menu. The Fade
Duration parameter determines the duration of the signal used for Cross
Fading.

Clicking on OK in the dialog box validates changes made to the settings. Click-
ing on Cancel cancels changes to Auto Fading settings.
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Figure 10–17.  Auto Fading Window

10.11.5 Spectrogram Options

The Spectrogram Options command in the Options Menu sets the Bandwidth
parameter and display settings (low clip level or high clip level) for spectrogram
computation by the Spectrogram command in the Processing Menu.

Clicking on Spectrogram Options opens a dialog box with options to select.
The spectrogram analysis Bandwidth parameter can be adjusted from 78 Hz
to 800 Hz, which permits either a narrow- or wide-band spectral analysis. The
Low Clip Level and High Clip Level parameters are used for spectrogram and
LPC spectrogram displays. These levels clip out the lower and higher
power-spectrum intensities of the computed spectra in order to obtain a better
visual display of the spectrogram. Clicking on OK in the dialog box validates
modifications to the settings. Clicking on Cancel cancels the modifications.
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10.12 Window Menu

The Window Menu contains several commands used to manipulate the
working windows in Sound Editor:

� Cascade
� Tile
� Show Clipboard

10.12.1 Cascade CONTROL  + K

The Cascade command in the Window Menu cascades the displayed
windows.

10.12.2 Tile CONTROL  + T

The Tile command in the Window Menu tiles the displayed windows (i.e., ar-
ranges the windows like tiles).

10.12.3 Show Clipboard CONTROL  + B

The Show Clipboard command in the Window Menu displays sound samples
currently in the Clipboard along with the sampling rate. The Clipboard display
window is similar to a Signal window, but it does not display frame markers,
and Edit commands cannot be used. Only Zoom functions are possible.

10.12.4 Displayed Windows List

Sound Editor maintains a list of the currently displayed windows. Click on the
desired window title to activate a window in the list.

10.13 Help Menu

The Help Menu contains several commands for on-line help:

� Contents
� Search for Help On
� About Sound Editor

10.13.1 Contents

The Contents command in the Help Menu displays a table of contents for on-
line Help information.
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10.13.2 Search For Help On

The Search For Help On command in the Help Menu provides quick access
to help on a selected topic.

10.13.3 About Sound Editor

The About Sound Editor command in the Help Menu provides information
about copyright and version of Sound Editor, as well as on the WINSDS board
present and PC status.
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11.1 Help Menu

If you are having trouble with a WINSDS command, go to the Help Menu. Use
the Summary command for an overview of topics covered, and/or Search for
Help on. . . for information on a specific topic. The About WINSDS command
provides information about the WINSDS copyright, version, board and PC
status.

11.2 Debugging WINSDS

Debug options are located in the Options submenu of the Setup Menu under
Miscellaneous. Each option is described in the following:

11.2.1 Examine Cursor

This command is used to examine cursor actions in support (troubleshooting)
operations. The command lists all commands from the current work session.

11.2.2 Debug

The following three Debug commands can be used when problems arise.
They are found in the Debug submenu of Miscellaneous under Options in the
Setup Menu.

� Event Tracking Window Toggle: Keeps track of mouse events, e. g.,
moving mouse up/down or clicking, and displays them in a window on the
screen.

� Disk Trace File Toggle: Keeps track of WINSDS messages that appear on
the screen and writes them to WINTRACE.TMP in the WINSDS directory
in DOS.

� Database Trace File Toggle: Keeps track of all data management
functions called within WINSDS and writes them to WINTRACE.TMP in
the WINSDS directory in DOS.

� Extended Trace File Toggle: Used with Disk Trace File Toggle or Database
Trace File Toggle to add more information to WINTRACE.TMP in the
WINSDS directory in DOS.
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11.3 Problems Installing WINSDS

A message, COMMDLG.DLL is in use appears, and then installation aborts.

COMMDLG.DLL is already installed in Sound Editor. Click on Ignore.

Messages indicate that files are missing, e.g., COMPOBJ.DLL, OLE2.DLL, 
STORAGE.DLL.

Reinstall the complete Windows package; then reinstall WINSDS.

11.4 Problems Starting WINSDS

After initial Setup, errors occur while running WINSDS.

Try to reinstall WINSDS using the default directory (C: \WINSDS). If that does
not solve the problem, check memory allocation for WINSDS and Windows.
Call the TI-Speech Applications Group for technical support.

WINSDS halts execution for a short time and then resumes. The hard disk 
drive seems busy.

If you have several other Windows applications running at the same time, try
to close them. Then verify that you have enough Virtual Memory allocated and
that your system has a minimum of 8 MB of RAM if running WINSDS under
WFW 3.11 or 16 MB of RAM if running WINSDS under Windows95�.

Note:

When low on memory, the Windows Memory Manager tries to recompact
scattered memory, and this process may result in a pause in execution once
in a while.

A fatal error occurs during execution.

Reset PC. If that doesn’t work, call the TI-Speech Applications Group for
technical support.

When WINSDS is started, a prompt asks if you would like to Edit a List.

The message occurs if there is a check before Invite to edit list at start-up in
the Start-up submenu of the Setup Menu. If you do not want the message to
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appear, click on the item, and the check mark disappears. The next time
WINSDS starts, the message will not appear.

The record light icon  on the Toolbar flashes red upon start-up.

The Invite to record at start-up option in the Start-up submenu of the Options
Menu is checked. If you do not want to begin recording automatically upon
start-up, click on the command, Invite to record at start-up. The check mark
disappears and the next time WINSDS is started, recording will not begin
automatically.

11.5 Problems Recording and Playing a Signal

Displays occur very slowly, especially signal displays and cursor movements.

Make sure you are using a 486 DX-33 or 486 DX2-66 PC (not a 386 PC).
Check memory allocation in WINSDS, Windows, and DOS.

An Overflow Message appears while you are attempting to display a signal, and you
return to Windows.

Extend Virtual Memory in Windows Control Panel, and verify that your system
has a minimum of 8 MB of RAM for WFW 3.11 or 16 MB for Windows95�.

LPC Quality is noisy when you play the recorded signal or the imported file.

� Check the following settings in the Station Configuration table in
Application Setup in the Setup Menu:

Coding Scheme 654P74

Maximum expected Pitch 1 or 2

Minimum expected Pitch 15 or 18.5

Voiced analysis Pre-emphasis 0

Unvoiced analysis Pre-emphasis 0

Energy of Voiced pick-up (excitation) 1.62

Energy of Unvoiced pick-up (excitation) 0.64

� Re-analyze the signal by clicking on Analyze Word in the Record Menu.
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� Select the entire signal in Signal window. Go to the Modify Menu, Energy
submenu, and click on Set Energy to Zero. When a box appears asking
you for a value, type in 8000 and click on OK.

The signal does not play when the Numerical Modifications window is displayed.

Use the appropriate function keys to listen to the different Play Modes. (See
section 6.4.4 for function key combinations for Play.)

WINSDS does not record (especially in a new application).

Go to the Recording Setup in the Setup Menu, and select Adjust Input Gain.
Adjust the Input Gain if you have not yet done so. Click on OK. Try to record
again.

11.6 Editing Problems

Cut Selection (Edit Menu) results in the deletion of the entire signal.

If your selection crosses a word boundary, words on both sides of the boundary
(indicated by a vertical green line on the Scale bar under the Signal display)
are highlighted and deleted. Or, you have tried to cut the first frame of the
displayed signal. Try using Split Current Word ( F3 ) and Delete Word com-
mands in the Edit Menu instead.

11.7 Problems with Lists

Words from the list are not recorded or analyzed in the Word Status table.

If the word labels in the list do not match the word labels of recorded words,
they show up as extra items in the Read a Word window.
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11.8 ROMSDS Problems

ROMSDS.TXT has an error message at the end indicating that it did not run.

If you have deleted a word in the application using the Delete a Word command
in the Miscellaneous submenu of the Modify Menu, have exited WINSDS, and
then have run ROMSDS in a later session, you get an error message due to
an incomplete Delete operation. Run Make (.RSD) Setup File and ROMSDS
again.

In Windows95� the ROMSDS.TXT file displayed after running ROMSDS may
not the latest version of the text file. Run Make (.RSD) Setup File and then
ROMSDS.

11.9 Problems with the 3x Chip

Using the 3x chip, when a Split Word is played, there is a loud click at the cut.

After changing the chip to 50C3x in the Setup Menu, wait 2-3 seconds.

11.10 MELP

Sound Editor doesn’t work on MELP applications.

MELP functions have not been implemented on Sound Editor.
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Table 11–1. DSP Module Error Codes and Messages

Error Code Error Message

1 DSP: No error reported.

2 DSP: Time out during speech acquisition. Check board and
cables.

3 DSP: Loss of synchronization during speech acquisition

4 DSP: The processor is busy.

5 DSP: THE DSP board cannot respond to the PC hosts’ com-
mands.

6 DSP: Time out during sending commands to board.

7 DSP: Time out during data block transfer from board.

8 DSP: Time out during data transfer from board.

9 DSP: Time out during data block transfer to board.

10 DSP: Time out during data transfer from board.

11 DSP: Time out during data transfer to board.

12 DSP: DSP board executable code file format

13 DSP: Bad DSP executable code file format

14 DSP: Bad DSP board executable code

15 DSP: Cannot load DSP board executable code file. Check board
address.

16 DSP: Cannot find transcoding table size.

17 DSP: Bad transcoding table file

18 DSP: Cannot load transcoding table file.

19 DSP: Number of the parameters in the transcoding table in error

20 DSP: Cannot find synthesis program file.
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A.1 LPC Analysis

Linear Predictive Coding (LPC) is the most widely used method of expressing
the transfer function of the filter representing the vocal tract. The basic theory
is that an audio signal can be approximated by a linear combination of past
outputs of a hypothetical filter with present inputs. In the case of speech sig-
nals, this filter is assumed to have the basic properties of the human vocal tract
(i.e., a uniform, open tube). In LPC there are two sources of excitation: periodic
impulse (voiced) and noise (unvoiced). Voiced excitation represents vocal-fold
vibration in the human vocal tract associated with vowels and some conso-
nants such as [r, l, w]. Unvoiced excitation represents friction noise associated
with consonants such as [f, s, h], and transient noise associated with conso-
nants such as [p, t, k].

Changes is the three-dimensional shape of the vocal tract over time are ac-
counted for by dividing the tube into ten smaller segments of equal length with
varying cross-sectional areas. The statistical method of least-squares is used
to estimate a set of coefficients representing sound propagation at the bound-
aries between segments.

The input frequency is determined by extracting the pitch period from the origi-
nal signal. An energy factor (or gain) is produced as a by-product of the analy-
sis algorithm. Parameters, generated by the method described in the previous
text, are valid for a finite time interval (5 ms to 20 ms).

A complete set of parameters is called an analysis frame. Within a given analy-
sis frame, digital samples of the signal are generated at a rate of 8 or 10 kHz.
Parameter values are updated several times within a frame by means of inter-
polation logic, which provides smooth transitions from one frame to the next.

Every 10 ms to 20 ms, LPC analysis updates the values of the following syn-
thesis parameters:

� Set of reflection coefficients representing linear prediction
� Type of excitation (voiced or voiceless)
� Energy of the excitation
� Pitch period (or pitch frequency) of voiced signals

In order to determine the values of these parameters, it is necessary to analyze
the speech signal to be synthesized. Analysis of the speech/sound signal to
be synthesized may result in imprecision leading to a degradation of the syn-
thesized signal (e. g., imprecise measurement of pitch period, choice of excita-
tion type at transitions between some consonants and vowels). The analysis
system used must allow for the correction of such errors. WINSDS and its pre-
cursors have been developed by Texas Instruments to meet this need.



 LPC Analysis

A-3  LPC Analysis

WINSDS allows for speech/sound recording from an external source (micro-
phone or line). It computes and codes linear prediction parameters and allows
for their modification. WINSDS also allows for sound editing (cutting words,
adding silence, inserting, deleting, etc.) Powerful ROM generation software
creates complete EPROM data with words/sounds that have been previously
recorded and coded.
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B.1 New Product Release Forms (TSP50C0x/1x)

The new product release form is used to track and document all the steps
involved in implementing a new speech code onto one of the parent speech
devices. Blank forms are provided in subsections B.1.1 through B.1.8 (note
that the addresses on these forms are subject to change). Copy the new
product release forms (NPRF) provided or get one from your TI field sales
office to initiate the implementation process. The next step is to complete
Section 1. As seen on the blank forms, Section 1 allows you to choose the
options pertinent to the parent device you wish to use. Section 1 also allows
you to choose your own customer part number used for ordering your parts.
If no customer part number is indicated, then TI defaults to the CSM1xxxxxx
part number for ordering purposes. Completion of the company name, project
name, and option fields is mandatory. Completion of all other fields in Section
1 is optional. After completion of Section 1, you must submit the NPRF (along
with your speech code) to the speech products group via your local TI field
sales office.

Once the speech products group receives the speech code and the NPRF, you
have completed the initial steps involved in implementing this code onto
production devices. Since all parent speech devices are mask programmable,
the speech code must first be converted into a format that the speech products
mask vendor can use to generate this new mask. This format is called a PG
output. Once this PG output is generated, the original speech code is
reconstructed from the PG output file and sent back to you for recheck. This
recheck ensures that the PG output file was generated correctly. Along with
the reconstructed speech code, the NPRF is also returned to you with Section
2 completed by TI. In this section, TI assigns your own CSMxxxxxx part
number and, in the case of packaged devices, TI also proposes a symbol
format to you. If you wish to deviate from the suggested symbol format, you
must consult TI for requested changes.

After you verify the reconstructed speech code and accept the proposed
symbol format, you are required to sign section 3 as authorization for TI to
generate the mask, prototypes, and risk units in accordance with the pertinent
purchase order. You then need to send or fax the NPRF to the speech products
group via the local TI field sales office. TI should have the prototypes shipped
to you approximately six weeks after receiving the NPRF with section 3 signed.
Once you receive these prototypes, you need to verify the functionality of the
prototypes, sign section 4, and send the NPRF (with section 4 signed) back
to TI. At this point, you can start ordering production units.
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B.1.1 New Product Release Form for TSP50C04

                           NEW PRODUCT RELEASE FORM
                                 FOR TSP50C04

SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)

Internal RC Oscillator (check one)
           ___  9.6  Mhz  (9.1Mhz – 10.1Mhz)
           ___  7.68 Mhz  (7.18Mhz – 8.18Mhz)
           ___       Mhz  ( +5% OR –5%)

Pulse width modulation (check one)
           ___  PW1
           ___  PW2

Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com
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B.1.2 New Product Release Form for TSP50C06

                           NEW PRODUCT RELEASE FORM
                                FOR TSP50C06

SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)

Internal RC Oscillator (check one)
           ___  9.6  Mhz  (9.1Mhz – 10.1Mhz)
           ___  7.68 Mhz  (7.18Mhz – 8.18Mhz)
           ___       Mhz  ( +5% OR –5%)

Pulse width modulation (check one)
           ___  PW1
           ___  PW2

Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com
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B.1.3 New Product Release Form for TSP50C10A

                           NEW PRODUCT RELEASE FORM
FOR TSP50C10A

SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)
           ___  single pin double ended (1A)

Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444
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B.1.4 New Product Release Form for TSP50C11A

                           NEW PRODUCT RELEASE FORM
FOR TSP50C11A

SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)
           ___  single pin double ended (1A)

Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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r******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444
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B.1.5 New Product Release Form for TSP50C12

                           NEW PRODUCT RELEASE FORM
                                 FOR TSP50C12

SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Option:
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D)
           ___  single pin double ended (1A)

LCD Drive:
           ___ Type A, Fast
           ___ Type B, Slow

Oscillator:
           ___  RC (Resistor/Capacitor)
           ___  CR (Ceramic Resonator)

Pulse width modulation (check one):
           ___  PW1
           ___  PW2

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)
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******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************

Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com
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B.1.6 New Product Release Form for TSP50C13

                           NEW PRODUCT RELEASE FORM
                                  FOR TSP50C13D
SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)

Internal RC Oscillator (check one)
           ___  9.6  Mhz  (9.1Mhz – 10.1Mhz)
           ___  7.68 Mhz  (7.18Mhz – 8.18Mhz)
           ___       Mhz  ( +5% OR –5%)

Pulse width modulation (check one)
           ___  PW1
           ___  PW2
Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com



 New Product Release Forms (TSP50C0x/1x)

B-15  Customer Information

B.1.7 New Product Release Form for TSP50C14

                           NEW PRODUCT RELEASE FORM
                                  FOR TSP50C14D
SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)

Internal RC Oscillator (check one)
           ___  9.6  Mhz  (9.1Mhz – 10.1Mhz)
           ___  7.68 Mhz  (7.18Mhz – 8.18Mhz)
           ___       Mhz  ( +5% OR –5%)

Pulse width modulation (check one)
           ___  PW1
           ___  PW2
Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com
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B.1.8 New Product Release Form for TSP50C19

                           NEW PRODUCT RELEASE FORM
                                  FOR TSP50C19
SECTION 1.  OPTION SELECTION
     This section is to be completed by the customer and sent to TI along with
     the microprocessor code and speech data.

Company:_____________________________   Division:_____________________________
Project Name:________________________   Purchase Order #:_____________________
Management Contact: _______________________________  Phone:(___) _____________
Technical Contact : _______________________________  Phone:(___) _____________
Customer Part Number:_____________________________

D/A Output (check one):
           ___  2 pin push–pull (2D)
           ___  single pin single ended (1D) (not recommended)

Internal RC Oscillator (check one)
           ___  9.6  Mhz  (9.1Mhz – 10.1Mhz)
           ___  7.68 Mhz  (7.18Mhz – 8.18Mhz)
           ___       Mhz  ( +5% OR –5%)
Pulse width modulation (check one)
           ___  PW1
           ___  PW2
Package Type (check one):
           ___ N (16 Pin)
           ___ die
           ___ SOWB (20 Pin)
                  ___ Tube
                  ___ Reel

******************************************************************************
SECTION 2. ASSIGNMENT OF TI PRODUCTION PART NUMBER
     The TI Part Number is to be completed by TI.

TI Part Number: _____________

SECTION 2B. PACKAGE UNIT SYMBOLIZATION
     This section is to be completed by the customer.
     The first line of the symbolization is fixed. Except EIA#/Logo.
     The second and third lines are to be filled in by the customer.

Top Side Symbolization (16pin ’N’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     ??? YMLLLLT       |  YM:   DATE CODE
                           |    <optional 13 char> |  T:    ASSY SITE
                           |    <optional 11 char> |  ???:  TI EIA NO. or
                           +–––––––––––––––––––––––+           TI LOGO

For ’16N’ packages, the customer may choose between 980 or the TI LOGO on the
first line.

Top Side Symbolization (20pin ’SOWB’)
                           +–––––––––––––––––––––––+  LLLL: LOT TRACE CODE
                           |     \T/ YMLLLLT       |  YM:   DATE CODE
                           |    <optional 10 char> |  T:    ASSY SITE
                           |    <optional  6 char> |  \T/:  TI LOGO
                           +–––––––––––––––––––––––+
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******************************************************************************
SECTION 3.  AUTHORIZATION TO GENERATE MASKS, PROTOTYPES, AND RISK UNITS
     This section is to be completed by the customer and sent to TI after
     after the following data has been met:
        
        1) The customer has verified that the TI computer generated data
           matches the original data.
        
        2) The customer approves of the symbolization format in Section 2B.
           (Applies to packaged devices only)

I hereby certify that the TI generated verification data has been checked and
found to be correct, and I authorize TI to generate masks, prototypes, and
risk units in accordance with purchase order in section 1 above. In addition, in
the instance that this is a packaged device, I also authorize TI to use the sym-
bolization format illustrated in section 2B on all devices.

By:_________________________________________    Title:________________________
Date:_____________________

(FAX this form to 214–480–7301. Attn: Code Release Team)

******************************************************************************
SECTION 4.  APPROVAL OF PROTOTYPES AND AUTHORIZATION TO START PRODUCTION
     This section is to be completed by the customer after prototype devices
     have been received and tested.

I hereby certify that the prototype devices have been received and tested and
found to be acceptable, and I authorize TI to start normal production in
accordance with purchase order #______________________.

By:_____________________________________________    Title:______________
Date:_____________________

******************************************************************************
Return to:   Texas Instruments, Inc.
             Attn: Code Release Team
             P.O. Box 660199, M/S 8718
             Dallas, TX 75266–0199

OR Fax to:   (214)480–7301
             Attn: Code Release Team

Have Questions?:
CALL:        Code Release Team
             (214)480–4444

OR E–MAIL:   code–rel@msp.sc.ti.com


